[Gta04-owner] Replicant: no sound during calls (L.B.)

L.B. lionel.broche at gmail.com
Fri Jan 9 18:31:37 CET 2015


On 06/01/15 14:02, Alexandre Roumiantsev wrote:
>> Date: Tue, 06 Jan 2015 10:22:12 +0000
>> From: "L.B." <lionel.broche at gmail.com>
>> To: gta04-owner at goldelico.com
>> Subject: Re: [Gta04-owner] Replicant: no sound during calls
>> Message-ID: <54ABB754.9070207 at gmail.com>
>> Content-Type: text/plain; charset="windows-1252"
>>
>> On 05/01/15 10:20, Lukas Maerdian wrote:
>>> Am 04.01.2015 um 23:35 schrieb L.B.:
>>>> On 04/01/15 10:18, Lukas Maerdian wrote:
>>>>> Am 03.01.2015 um 23:31 schrieb L.B.:
>>>>>> Hi all,
>>>>>>
>>>>>> First of all I wish you a very happy new year!
>>>>>> For a good start in 2015 I decided to try Replicant on my GTA04
>> and
>>>>>> downloaded the auto-install script from Goldelico git repo (which
>> looks
>>>>>> recently updated):
>>>>>>
>>>>>> http://git.goldelico.com/?p=gta04-makesd.git;a=blob;f=makesd-replicant;h=630e92ffc2baf5e3d332cf11896317fc61e2fa1d;hb=HEAD
>>>>>>
>>>>>> It all went well and installed replicant on my 32GB SDcard. All
>> booted
>>>>>> very well too and within 5 min I could use the Wifi without
>> problem and
>>>>>> Bluetooth also seemed to work (I have to find another device to
>> make
>>>>>> sure but the slider does witch correctly).
>>>>>> I could install a couple of packages to record and play sound,
>> configure
>>>>>> the ring tones and other niceties.
>>>>>> Then I tested the calls: I can make phone calls and receive some,
>> but I
>>>>>> cannot hear anything nor can I speak to the other when the call
>> starts.
>>>>>> No sound at all during the call, on both side.
>>>>>> I tried modifiying the sound preferences but it looks like the
>> problem
>>>>>> is deeper than that. Is this a known bug?
>>>>>> By the way, congratulations for all the work on replicant! last
>> time I
>>>>>> tried it was a year ago and a lot has been done since then.
>>>>> Hi!
>>>>>
>>>>> I recently implemented software-routing for audio in voice calls
>> and the
>>>>> changes are working and in the git repository. But the latests
>> testing
>>>>> image (which makesd makes use of) does not yet include those
>> changes.
>>>>> So you would either need to compile Replicant yourself, according
>> to
>>>>> this documentation:
>>>>>   http://projects.goldelico.com/p/gta04-replicant/page/Replicant-4/
>>>>>
>>>>> Or you would need to wait for the release of a new Goldelico
>> Replicant
>>>>> version, which I hope to be soon, but I want to fix one last bug
>> (modem
>>>>> suspend/resume) before doing a new testing release.
>>>>>
>>>>> Best,
>>>>>   Lukas
>>>>>
>>>> I followed the instructions from the doc (I also had to use 'sudo
>>>> update-alternatives --config javac' to use java-7-openjdk-amd64
>> because
>>>> version 8 is not accepted for compilation) but I ran into some
>> problems:
>>>> first, both the bootimage and tarball processes complain about not
>>>> finding device/goldelico/gta04/recovery.fstab, plus a few other
>> errors:
>>>> *cut*
>>>> Checking build tools versions...
>>>> grep: device/goldelico/gta04/recovery.fstab: No such file or
>> directory
>>>> fatal: No annotated tags can describe
>>>> '161f26dcfb2f9ff69e3ba5457d8074157f1ced33'.
>>>> However, there were unannotated tags: try --tags.
>>>> fatal: No annotated tags can describe
>>>> '161f26dcfb2f9ff69e3ba5457d8074157f1ced33'.
>>>> However, there were unannotated tags: try --tags.
>>>> fatal: No annotated tags can describe
>>>> '161f26dcfb2f9ff69e3ba5457d8074157f1ced33'.
>>>> However, there were unannotated tags: try --tags.
>>>> fatal: No annotated tags can describe
>>>> '161f26dcfb2f9ff69e3ba5457d8074157f1ced33'.
>>>> However, there were unannotated tags: try --tags.
>>>> *cut*
>>>> This did not prevent the process, though. Are these really
>> problematic?
>>> Hi.
>>>
>>> I see those too, they are not problematic. It's just that git cannot
>>> find certain tags.
>>>
>>>> Then the tarball fails to be generated with the following error:
>>>> *cut*
>>>> host C++: libcts_audio_quality <=
>> cts/suite/audio_quality/lib/src/Adb.cpp
>>>> In file included from /usr/include/stdlib.h:25:0,
>>>>                  from cts/suite/audio_quality/lib/src/Adb.cpp:16:
>>>> /usr/include/features.h:323:26: fatal error: bits/predefs.h: No
>> such
>>>> file or directory
>>>> compilation terminated.
>>>> *cut*
>>>> Where is that file?
>>> Hmm, sounds like you're missing some of the build dependencies.
>> Please
>>> check the official Replicant documentation and see if you have all
>> the
>>> dependencies installed:
>>> http://redmine.replicant.us/projects/replicant/wiki/BuildDependenciesInstallation
>>>
>>> Best,
>>>   Lukas
>>>
>>>
>>>
>>> _______________________________________________
>>> Gta04-owner mailing list
>>> Gta04-owner at goldelico.com
>>> http://lists.goldelico.com/mailman/
>>> listinfo.cgi/gta04-owner
>> Ok, I got it to work this morning. I had a problem yesterday because
>> the
>> modem, wifi and the battery state sensor were not initialised, so the
>> battery was detected as depleted and  the phone switched off as soon
>> as
>> possible. I think this happened because I did not use an up-to-date
>> MLO
>> in the boot partition.
>>
>> The image works well now, I can definitely hear the other side and
>> they
>> can hear me, but the sound quality is not great. The voice that I
>> receive is distorted (it sounds like a bip after each sound, a bit
>> like
>> a DC  bias but repetitively) and the other person harldy hears me.
>> I'll
>> try adjusting the audio but the distorsion is quite a problem.
>>
>> Other than that, text messaging works fine, audio works great (outside
>> calls) and wifi is working too. I'll check how long the battery lasts
>> now.
>>
>> Thanks for the help,
>>
>> Lionel
> Congratulation with this success. I suggest to you to test Replicant
> multi-partitions image as well. You can find build instruction here:
> http://redmine.replicant.us/projects/replicant/wiki/GTA04Build
> installation instruction here:
> http://redmine.replicant.us/projects/replicant/wiki/GTA04Installation
> For start you can find ready files for installation in tar file here:
> https://drive.google.com/file/d/0B-rRgKAzYyoBVXlpNmRwZEtiM2M/view?usp=sharing
>
> Good lack in new year
>
>
> _______________________________________________
> Gta04-owner mailing list
> Gta04-owner at goldelico.com
> http://lists.goldelico.com/mailman/listinfo.cgi/gta04-owner
Excellent, thanks a lot! I'll give a go at multiboot, I wanted to try
that at some point.

A good year to you too!

Lionel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20150109/5936ee34/attachment.html>


More information about the Gta04-owner mailing list