[Gta04-owner] current state of bluetooth headset support in QtMoKo

Sebastian Reinhardt snr at lmv-hartmannsdorf.de
Thu May 15 22:48:59 CEST 2014

Am 15.05.2014 08:18, schrieb Radek Polak:
> Hi Sebastian,
> maybe it broke with never bluez version - something like this:
> https://github.com/radekp/qtmoko/issues/156
> I used this page to implement it:
> http://wiki.openmoko.org/wiki/A2DP
> IIRC you should have /home/root/.asoundrc - this tells alsa about your 
> bluetooth headset. Can you check if QtMoko correctly creates it?
> Then you can try from SSH:
> ssh root at
> . /opt/qtmoko/qpe.env
> mplayer -ao alsa:device=bluetooth /path/to/file.ogg
> This could print something useful. Another thing that might have 
> broken a2dp could be pulseaudio - IIRC we were not using it in older 
> releases where it was working. So maybe it would be worth to disable 
> pulseaudio somehow and try without it. You could also try to make A2DP 
> working with pulseaudio - google "a2dp pulseaudio" should help here.
> Regards
> Radek
Thanks Radek, I tried it again,

as soon as I connect to headset by using "A2DP"- profile and setting 
bluetooth as default output device, this file is created:
root at snrgta04:/home/root# cat .asoundrc
# /org/bluez/1857/hci0/dev_C8_8B_47_01_xx_xx
pcm.!default {
    type plug
    slave.pcm "bluetooth"

ctl.mixer0 {
    type hw
    card 0

pcm.bluetooth {
        type bluetooth
        device "C8_8B_47_01_xx_xx"
        profile "auto"

Seems to be ok, except the underscores instead of ":" in bluetooth 
address. Not sure, if does matter?

Then I tried mplayer again and with ". /opt/qtmoko/qpe.env" before 
mplayer command it is playing now. But I can not hear anything. If I 
start mplayer without "device"- option, the speaker is playing the song! 
So which control in alsamixer is associated with my headset? I treid to 
mute/unmute and raise volume in alsamixer with every control slider, 
without sound out of my headset.

root at snrgta04:~# mplayer -ao alsa:device=bluetooth 
Documents/audio/x-wav/06\ -\ Shut\ Up.mp3
MPlayer svn r34540 (Debian), built with gcc-4.6 (C) 2000-2012 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote 
Playing Documents/audio/x-wav/06 - Shut Up.mp3.
libavformat version 53.21.1 (external)
Mismatching header version 53.19.0
Audio only file format detected.
Clip info:
  Title: Shut Up (feat. Duece Poppito o
  Artist: Trick Daddy
  Album: Book Of Thugs: Chapter A.K., V
  Track: 6
  Genre: Rap
Load subtitles in Documents/audio/x-wav/
Requested audio codec family [mpg123] (afm=mpg123) not available.
Enable it at compilation.
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
libavcodec version 53.35.0 (external)
Mismatching header version 53.32.2
AUDIO: 44100 Hz, 2 ch, floatle, 183.4 kbit/6.50% (ratio: 22921->352800)
Selected audio codec: [ffmp3float] afm: ffmpeg (FFmpeg MPEG layer-3 audio)
[AO_ALSA] Format floatle is not supported by hardware, trying default.
AO: [alsa] 44100Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   0.3 (00.3) of 262.0 (04:22.0) ??,?%


the syslog tells me this:
May 15 22:30:34 snrgta04 kernel: [ 5839.499237] input: C8:8B:47:01:13:AA 
as /devices/virtual/input/input8
May 15 22:30:47 snrgta04 pulse.sh: I: [pulseaudio] client.c: Created 6 
"Native client (UNIX socket client)"
May 15 22:30:47 snrgta04 pulse.sh: I: [pulseaudio] client.c: Freed 6 
"Native client (UNIX socket client)"
May 15 22:30:47 snrgta04 pulse.sh: I: [pulseaudio] protocol-native.c: 
Connection died.

Result: Silence! Sorry!

What type of bluetooth device did You use for testing? Speaker or 
headset (with/without mic)?

Kind regards

Sebastian Reinhardt

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20140515/02d4dbfb/attachment.html>

More information about the Gta04-owner mailing list