[Gta04-owner] current state of bluetooth headset support in QtMoKo

Radek Polak psonek2 at seznam.cz
Thu May 15 08:18:59 CEST 2014

On Thursday, May 15, 2014 00:26:36 Sebastian Reinhardt wrote:

> Thanks Radek, I tried, but without success!
> I used an different Headset, because the VMX200 does not support A2DP-
> profile.
> The one I tried is an Nolan N-Com B4. This supports following profiles:
> ----------------------------------------------------
> hcitool info C8:8B:47:01:xx:xx
> Requesting information ...
>          BD Address:  C8:8B:47:01:xx:xx
>          Device Name: N-Com B4 Bastel
>          LMP Version: 3.0 (0x5) LMP Subversion: 0x1982
>          Manufacturer: Cambridge Silicon Radio (10)
>          Features page 0: 0xff 0xff 0x8f 0xfe 0x9b 0xff 0x59 0x83
>                  <3-slot packets> <5-slot packets> <encryption> <slot
> offset>
>                  <timing accuracy> <role switch> <hold mode> <sniff mode>
>                  <park state> <RSSI> <channel quality> <SCO link> <HV2
> packets>
>                  <HV3 packets> <u-law log> <A-law log> <CVSD> <paging
> scheme>
>                  <power control> <transparent SCO> <broadcast encrypt>
>                  <EDR ACL 2 Mbps> <EDR ACL 3 Mbps> <enhanced iscan>
>                  <interlaced iscan> <interlaced pscan> <inquiry with RSSI>
>                  <extended SCO> <EV4 packets> <EV5 packets> <AFH cap.
> slave>
>                  <AFH class. slave> <3-slot EDR ACL> <5-slot EDR ACL>
>                  <sniff subrating> <pause encryption> <AFH cap. master>
>                  <AFH class. master> <EDR eSCO 2 Mbps> <EDR eSCO 3 Mbps>
>                  <3-slot EDR eSCO> <extended inquiry> <simple pairing>
>                  <encapsulated PDU> <non-flush flag> <LSTO> <inquiry TX
> power>
>                  <extended features>
>          Features page 1: 0x01 0x00 0x00 0x00 0x00 0x00 0x00 0x00
> ----------------------------------------------------
> I am able to connect it with "Connect audio (A2DP)". Then I get an
> message, I had to install "bluez-audio", but this is already installed!
> I choose "yes". After this procedure is finished, I was asked to use
> bluetooth as default audio output => "Yes". Trying to play anything with
> Qmplayer => complete silence!

Hi Sebastian,
maybe it broke with never bluez version - something like this:


I used this page to implement it:


IIRC you should have /home/root/.asoundrc - this tells alsa about your 
bluetooth headset. Can you check if QtMoko correctly creates it?

Then you can try from SSH:

	ssh root at
	. /opt/qtmoko/qpe.env
	mplayer -ao alsa:device=bluetooth /path/to/file.ogg

This could print something useful. Another thing that might have broken a2dp 
could be pulseaudio - IIRC we were not using it in older releases where it was 
working. So maybe it would be worth to disable pulseaudio somehow and try 
without it. You could also try to make A2DP working with pulseaudio - google 
"a2dp pulseaudio" should help here.



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20140515/902dae45/attachment-0001.html>

More information about the Gta04-owner mailing list