[Gta04-owner] current state of bluetooth headset support in QtMoKo

Sebastian Reinhardt snr at lmv-hartmannsdorf.de
Thu May 15 00:54:35 CEST 2014

Am 14.05.2014 09:27, schrieb Radek Polak:
> On Wednesday, May 14, 2014 00:22:36 Sebastian Reinhardt wrote:
> > And now? How did You get A2DP working, Radek?
> Hi,
> i think it works straight from the QtMoko GUI. This is from v26 changelog:
> "A2DP (bluetooth audio) support works too but with some glitches. You 
> need
> headset with A2DP support. After pairing press "Supported services" from
> bluetooth device context menu. New button "Connect audio (A2DP)" should then
> appear. Sometimes it fails to connect. For me it help putting headset in
> pairing mode, restart phone and then the button works."
> Then you can try launch Qmplayer and it should ask you to play on headset.
> BR
> Radek
Thanks Radek, I tried, but without success!
I used an different Headset, because the VMX200 does not support A2DP- 
The one I tried is an Nolan N-Com B4. This supports following profiles:
hcitool info C8:8B:47:01:xx:xx
Requesting information ...
         BD Address:  C8:8B:47:01:xx:xx
         Device Name: N-Com B4 Bastel
         LMP Version: 3.0 (0x5) LMP Subversion: 0x1982
         Manufacturer: Cambridge Silicon Radio (10)
         Features page 0: 0xff 0xff 0x8f 0xfe 0x9b 0xff 0x59 0x83
                 <3-slot packets> <5-slot packets> <encryption> <slot 
                 <timing accuracy> <role switch> <hold mode> <sniff mode>
                 <park state> <RSSI> <channel quality> <SCO link> <HV2 
                 <HV3 packets> <u-law log> <A-law log> <CVSD> <paging 
                 <power control> <transparent SCO> <broadcast encrypt>
                 <EDR ACL 2 Mbps> <EDR ACL 3 Mbps> <enhanced iscan>
                 <interlaced iscan> <interlaced pscan> <inquiry with RSSI>
                 <extended SCO> <EV4 packets> <EV5 packets> <AFH cap. 
                 <AFH class. slave> <3-slot EDR ACL> <5-slot EDR ACL>
                 <sniff subrating> <pause encryption> <AFH cap. master>
                 <AFH class. master> <EDR eSCO 2 Mbps> <EDR eSCO 3 Mbps>
                 <3-slot EDR eSCO> <extended inquiry> <simple pairing>
                 <encapsulated PDU> <non-flush flag> <LSTO> <inquiry TX 
                 <extended features>
         Features page 1: 0x01 0x00 0x00 0x00 0x00 0x00 0x00 0x00

I am able to connect it with "Connect audio (A2DP)". Then I get an 
message, I had to install "bluez-audio", but this is already installed! 
I choose "yes". After this procedure is finished, I was asked to use 
bluetooth as default audio output => "Yes". Trying to play anything with 
Qmplayer => complete silence!

Kind regards

Sebastian Reinhardt

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20140515/8d39599d/attachment.html>

More information about the Gta04-owner mailing list