[Gta04-owner] Modem reenummerating (was: Re: Crowdfunding an Ubuntu smartphone)

Dr. H. Nikolaus Schaller hns at goldelico.com
Tue Aug 27 15:06:44 CEST 2013


<blurb>
Now,
I am back from holidays with really weak connectivity. I did have good GSM voice
but almost no data. No EDGE and weak GPRS - I did have up to 30 seconds ping
response time... And I must admit that it was not a GTA04, but a different commercial
device. And - it also has some strange Modem hangup problem. When tethering
through Bluetooth I had to switch the device to airplane mode from time to time to
reboot the modem. And then the bluetooth connection worked again.
</blurb>

Am 27.08.2013 um 00:56 schrieb NeilBrown:

> On Mon, 26 Aug 2013 16:59:52 +0200 Radek Polak <psonek2 at seznam.cz> wrote:
> 
>> On Monday, August 26, 2013 12:47:42 PM Radek Polak wrote:
>>> On Sunday, August 25, 2013 01:22:00 PM Christ van Willegen wrote:
>>>> On Sat, Aug 24, 2013 at 11:24 PM, Lukas Märdian <luk at slyon.de> wrote:
>>>>> Am 24.08.2013 23:04, schrieb NeilBrown:
>>>>>> I'm starting to think the the re-enumeration could be an omap-usb
>>>>>> problem. I turned off a couple of power-saving features and the rate
>>>>>> at which my modem reenumerates went way down. Sometimes the the modem
>>>>> 
>>>>> Hmm could this by any chance have something to do with the infamous
>>>>> Linux-USB problem, recently pointed out by Sarah Sharp?
>>>>> 
>>>>>  http://permalink.gmane.org/gmane.linux.usb.general/93288
>>>> 
>>>> Well, it's worth a try!
>>>> 
>>>> I get a _lot_ of flack about not being reachable from my wife, who
>>>> repeatedly calls on me to drop the GTA project and get another phone
>>>> so I am reliably reachable again :-(
>>> 
>>> I just tried the patch and it does not help with our problem :(
>> 
>> Btw the reenumaration happens even without suspend/resume at all.
> 
> That at least can be fixed I think.
> Just revert 8446a5252c21648d80c10282fe555f310c86 in my 3.7-gta04 branch.
> I copied it from 
>   http://lists.meego.com/pipermail/meego-commits/2011-August/033297.html
> though that doesn't appear to exist any more...
> This seems similar:
> http://article.gmane.org/gmane.comp.handhelds.meego.scm/26609/
> 
> Anyway I reverted that and the "GTA04 enable off mode" patch and now I only

Maybe I am lacking some background on that - what is the off-mode and this patch
intended to do?

> get a reenummeration every couple of days.

We have a really subtle problem and don't know if it is by
1. modem firmware
2. linux kernel
3. hardware
4. user space triggered (which I think is the least probable)

For 1. the flashing tool I have got does not run on our kernel. It segfaults...
So we can't compare different firmware versions.

And, I had asked OPTION (indirectly through our connections) and they were not
aware of such a problem. So in their view it does not even exist.

I.e. they won't give us easily a different firmware where *they* have fixed
anything.

And unless we order more Modem modules for the GTA04A5 we won't get
modems already having a newer firmware pre-installed.


For 2. it could be something in the drivers. I know that there was an issue with the
RING indication data packet sent over USB to the HSO driver. The idea of this code
is that the /dev/tty really has a RI modem status signal, when the modem gets a
ring signal. There appears to be a mismatch of the firmware of the GTM601 and the
original driver in the kernel code, so that the modem sends a code that the kernel
driver does not properly catch and the connection hangs up. Maybe the GTM601
virtual port driver recognizes this and disconnects/reconnects itself.

But: I think this has been patched - at least in the 2.6.32 kernel.
And then I did not see it any more in my tests (but I have not tested anything
in that direction for a while).

Nevertheless, some similar thing could happen and has not yet been patched.


For 3. there are even two scenarios. One is that the TUSB3322 PHY interface
chip is not really 100% compatible to the DM3730 PHY interface. And indeed
there is some erratum that there may be some hangup when using the TUSB3322
and TI recommends to use a different PHY chip. This is an option planned for
the GTA04A5 revision.

So it could be that the USB connection hangs up itself, especially when the CPU
is in suspend.

This is something where we can add a timeout and reset the TUSB - but that of
course introduces approx. 1 second of delay.

Another HW related issue could be that the GSM/UMTS transmitter disturbs the USB
signals going between the modem and the TUSB-PHY chip. But this is quite unlikely.


What makes me worried most is not the problem, but that there is no Issue report here:

	http://projects.goldelico.com/p/gta04-kernel/issues/

For further analysis of this issue we need:

1. collected reports from as many users how they see and experience the bug
2. a reference setup how to enforce the bug
3. always describe which kernel version is used (it may depend on that!)


BR,
Nikolaus



More information about the Gta04-owner mailing list