[Gta04-owner] Modem reenummerating (was: Re: Crowdfunding an Ubuntu smartphone)

NeilBrown neilb at suse.de
Tue Aug 27 23:18:52 CEST 2013


On Tue, 27 Aug 2013 15:06:44 +0200 "Dr. H. Nikolaus Schaller"
<hns at goldelico.com> wrote:

> 
> <blurb>
> Now,
> I am back from holidays with really weak connectivity. I did have good GSM voice
> but almost no data. No EDGE and weak GPRS - I did have up to 30 seconds ping
> response time... And I must admit that it was not a GTA04, but a different commercial
> device. And - it also has some strange Modem hangup problem. When tethering
> through Bluetooth I had to switch the device to airplane mode from time to time to
> reboot the modem. And then the bluetooth connection worked again.
> </blurb>
> 
> Am 27.08.2013 um 00:56 schrieb NeilBrown:
> 
> > On Mon, 26 Aug 2013 16:59:52 +0200 Radek Polak <psonek2 at seznam.cz> wrote:
> > 
> >> On Monday, August 26, 2013 12:47:42 PM Radek Polak wrote:
> >>> On Sunday, August 25, 2013 01:22:00 PM Christ van Willegen wrote:
> >>>> On Sat, Aug 24, 2013 at 11:24 PM, Lukas Märdian <luk at slyon.de> wrote:
> >>>>> Am 24.08.2013 23:04, schrieb NeilBrown:
> >>>>>> I'm starting to think the the re-enumeration could be an omap-usb
> >>>>>> problem. I turned off a couple of power-saving features and the rate
> >>>>>> at which my modem reenumerates went way down. Sometimes the the modem
> >>>>> 
> >>>>> Hmm could this by any chance have something to do with the infamous
> >>>>> Linux-USB problem, recently pointed out by Sarah Sharp?
> >>>>> 
> >>>>>  http://permalink.gmane.org/gmane.linux.usb.general/93288
> >>>> 
> >>>> Well, it's worth a try!
> >>>> 
> >>>> I get a _lot_ of flack about not being reachable from my wife, who
> >>>> repeatedly calls on me to drop the GTA project and get another phone
> >>>> so I am reliably reachable again :-(
> >>> 
> >>> I just tried the patch and it does not help with our problem :(
> >> 
> >> Btw the reenumaration happens even without suspend/resume at all.
> > 
> > That at least can be fixed I think.
> > Just revert 8446a5252c21648d80c10282fe555f310c86 in my 3.7-gta04 branch.
> > I copied it from 
> >   http://lists.meego.com/pipermail/meego-commits/2011-August/033297.html
> > though that doesn't appear to exist any more...
> > This seems similar:
> > http://article.gmane.org/gmane.comp.handhelds.meego.scm/26609/
> > 
> > Anyway I reverted that and the "GTA04 enable off mode" patch and now I only
> 
> Maybe I am lacking some background on that - what is the off-mode and this patch
> intended to do?

Different modules in the OMAP can be in one of 4 modes: Active, Idle,
Retention, and Off.
Retention is a low power mode which still retains all registers.
Off is a much lower power mode which doesn't.

As you might imagine, going to Retention mode is a lot easier than going to
Off mode.
Linux does contain code to support Off mode but it is disabled by default.
The patch I mentioned simply enables it (and works around one bug that I
found).

Going to Off mode definitely saves quite a few mAmps, but appears to
introduce some instability.  We sometimes get strange errors on resume which
causes various processes (like dbus) to get SIGBUS, and it makes the USB
re-enumeration problem worse.

> 
> 
> For 3. there are even two scenarios. One is that the TUSB3322 PHY interface
> chip is not really 100% compatible to the DM3730 PHY interface. And indeed
> there is some erratum that there may be some hangup when using the TUSB3322
> and TI recommends to use a different PHY chip. This is an option planned for
> the GTA04A5 revision.
> 
> So it could be that the USB connection hangs up itself, especially when the CPU
> is in suspend.
> 
> This is something where we can add a timeout and reset the TUSB - but that of
> course introduces approx. 1 second of delay.

There certainly may be room to make more use of the PHY reset line.  As far
as I can tell it is only reset once at boot and never again.

However it seems to fail particularly on resume and if we are resuming
because of an incoming phone call, it isn't a good time to reset anything -
that would almost certainly hang up the call :-(
Maybe a pre-emptive reset when suspending???

NeilBrown
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 828 bytes
Desc: not available
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20130828/0ebc73a2/attachment.bin>


More information about the Gta04-owner mailing list