[Gta04-owner] Line echo on voice calls with headset....

NeilBrown neilb at suse.de
Sat Sep 15 03:25:32 CEST 2012


On Fri, 14 Sep 2012 10:28:12 +0200 "Dr. H. Nikolaus Schaller"
<hns at goldelico.com> wrote:

> 
> Am 14.09.2012 um 09:58 schrieb NeilBrown:
> 
> > 
> > Hi,
> > I've been experimenting with my headset today and discovered that there is
> > fairly substantial line-echo.
> > 
> > i.e. I run
> >     arecord | aplay
> > 
> > having set the mixer settings to record from the headset and play back to the
> > headset.  When I talk I hear myself with a short delay, which is exactly
> > what I expect.  However when I stop talking I keep hearing an echo, which
> > repeats and repeats with only minimal loss of clarity each time.
> > I've confirmed that it is not an acoustic echo - covering up the headphones
> > and the microphone make no difference at all - they don't even make it a
> > little bit quieter.
> > 
> > I tried to play some music out the headphones and record from the headset
> > mic at the same time and I get the music back quite clearly.  I tried the
> > same without the headphones plugged in, and the recording doesn't pick up
> > any music.  That seems to confirm line-echo in the headset.
> > I tried 2 different headsets and they both produce the same result.
> > 
> > Is this expected?
> 
> No...
> 
> > 
> > When I tried calling my wife she reported a significant echo of everything
> > she said, presumably due to this line echo.  When I use the builtin mic and
> > earpiece there is no such echo (or much less).
> > 
> > I suspect we might be able to eliminate the echo by tuning the echo
> > cancelling software, but I really feel that it shouldn't be happening in the
> > first place.
> > 
> > Any ideas?
> 
> It may be related to the pin layout of the headset which may connect
> the microphone to one of the audio out channels.
> 
> Which models are you using? Are they "Nokia" compatible?

I bought a headset which claimed to be Nokia compatible for about $4 on
Ebay.  I think there is a reason it was that cheap.  The left and right
channels are swapped, and the common was on the shield rather than the first
ring.  So it sort-of worked, but sound was a bit muffled unless  I pressed
the button (which sorted 'mic' and 'common' so effectively 'common' was
connected to the correct pin).
I re-soldered a connection so that 'common' is now on the first ring and it
works much better - mic recording is clean and headset sound is clear.  But I
get the line echo.

The other headset is a 3.5mm which I've got a 3.5mm -> 2.5mm (straight
though) adapter for.  I don't recall where it came from but as it is all
white I'm guessing it might be for some Apple device (not that we have any
iPhones in the family).   It too functions perfectly except for the line
echo.  If any pins were swapped I'm fairly sure that either the headphone
sound or the mic recording would be compromised.


> 
> > Anyone else get the same result?
> 
> I have just tried with the hw-validation kernel with a 4-pin Nokia headset
> (I think it came from a N770 or N800) and I get only noise from the
> headset mic using the scripts from here:
> 
> 	http://projects.goldelico.com/p/gta04-kernel/page/Sound/

Strange.  I tried those setting and still get the infinite echo.

> 
> Internal mic is fine.
> 
> It changes if I press the mic button, although it should disappear
> since the mic input will be grounded then.

I definitely get mic input being muted when I press the button.

> 
> So it may be everything from hardware bug to ALSA driver bug
> (setting something wrongly in the microphone path). It may also
> be some issue with AGC. Or the TVout is not switched off completely
> and we get a "video noise".

My 'Nokia' headset is two parts.  The mic unit has the mic and button and a
cable with the 4-pin 2.5mm plug.  It also has a socket into which a regular
set of headphones with 3-pin 3.5mm plug can be inserted.

When I unplug the headphones, the echo stops.
So maybe there is some inductive coupling?  When the headphones are inserted,
the audio-out lines form a circuit and current can flow.  Somehow this
current induces a current in the mic wire?

I'm unlikely to ever want to actually make a call from the headset so this
isn't really a practical problem for me, and if other people don't get the
same echo, I guess I can just forget about it...

Thanks,
NeilBrown



> 
> Generally these 2.5mm connectors are also not very reliable - but
> we have no space for a 3.5mm (4 pin).
> 
> BR,
> Nikolaus
> _______________________________________________
> Gta04-owner mailing list
> Gta04-owner at goldelico.com
> http://lists.goldelico.com/mailman/listinfo/gta04-owner

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 828 bytes
Desc: not available
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20120915/05a57350/attachment.bin>


More information about the Gta04-owner mailing list