[Gta04-owner] Line each on voice calls with headset....

Dr. H. Nikolaus Schaller hns at goldelico.com
Fri Sep 14 10:28:12 CEST 2012


Am 14.09.2012 um 09:58 schrieb NeilBrown:

> 
> Hi,
> I've been experimenting with my headset today and discovered that there is
> fairly substantial line-echo.
> 
> i.e. I run
>     arecord | aplay
> 
> having set the mixer settings to record from the headset and play back to the
> headset.  When I talk I hear myself with a short delay, which is exactly
> what I expect.  However when I stop talking I keep hearing an echo, which
> repeats and repeats with only minimal loss of clarity each time.
> I've confirmed that it is not an acoustic echo - covering up the headphones
> and the microphone make no difference at all - they don't even make it a
> little bit quieter.
> 
> I tried to play some music out the headphones and record from the headset
> mic at the same time and I get the music back quite clearly.  I tried the
> same without the headphones plugged in, and the recording doesn't pick up
> any music.  That seems to confirm line-echo in the headset.
> I tried 2 different headsets and they both produce the same result.
> 
> Is this expected?

No...

> 
> When I tried calling my wife she reported a significant echo of everything
> she said, presumably due to this line echo.  When I use the builtin mic and
> earpiece there is no such echo (or much less).
> 
> I suspect we might be able to eliminate the echo by tuning the echo
> cancelling software, but I really feel that it shouldn't be happening in the
> first place.
> 
> Any ideas?

It may be related to the pin layout of the headset which may connect
the microphone to one of the audio out channels.

Which models are you using? Are they "Nokia" compatible?

> Anyone else get the same result?

I have just tried with the hw-validation kernel with a 4-pin Nokia headset
(I think it came from a N770 or N800) and I get only noise from the
headset mic using the scripts from here:

	http://projects.goldelico.com/p/gta04-kernel/page/Sound/

Internal mic is fine.

It changes if I press the mic button, although it should disappear
since the mic input will be grounded then.

So it may be everything from hardware bug to ALSA driver bug
(setting something wrongly in the microphone path). It may also
be some issue with AGC. Or the TVout is not switched off completely
and we get a "video noise".

Generally these 2.5mm connectors are also not very reliable - but
we have no space for a 3.5mm (4 pin).

BR,
Nikolaus


More information about the Gta04-owner mailing list