[Gta04-owner] Line each on voice calls with headset....

NeilBrown neilb at suse.de
Fri Sep 14 09:58:42 CEST 2012


Hi,
 I've been experimenting with my headset today and discovered that there is
 fairly substantial line-echo.

 i.e. I run
     arecord | aplay

 having set the mixer settings to record from the headset and play back to the
 headset.  When I talk I hear myself with a short delay, which is exactly
 what I expect.  However when I stop talking I keep hearing an echo, which
 repeats and repeats with only minimal loss of clarity each time.
 I've confirmed that it is not an acoustic echo - covering up the headphones
 and the microphone make no difference at all - they don't even make it a
 little bit quieter.

 I tried to play some music out the headphones and record from the headset
 mic at the same time and I get the music back quite clearly.  I tried the
 same without the headphones plugged in, and the recording doesn't pick up
 any music.  That seems to confirm line-echo in the headset.
 I tried 2 different headsets and they both produce the same result.

 Is this expected?

 When I tried calling my wife she reported a significant echo of everything
 she said, presumably due to this line echo.  When I use the builtin mic and
 earpiece there is no such echo (or much less).

 I suspect we might be able to eliminate the echo by tuning the echo
 cancelling software, but I really feel that it shouldn't be happening in the
 first place.

 Any ideas?

 Anyone else get the same result?

NeilBrown
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 828 bytes
Desc: not available
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20120914/4f5b79c0/attachment.bin>


More information about the Gta04-owner mailing list