[Gta04-owner] Hints for installing QtMoko on recently delivered GTA04 boards

Dr. H. Nikolaus Schaller hns at goldelico.com
Thu Oct 25 15:14:12 CEST 2012


Hi,

it appears we have found a potential source of issues when
you get a recently new GTA04 with preinstalled Debian/LXDE
image and then install QtMoko following these instructions:

	http://sourceforge.net/projects/qtmoko/files/GTA04/

The problem is that qtmoko-fat-v48.tar.gz contains some
older variant of u-boot and boot.scr and this may be executed
when starting QtMoko from SD. This may result in a downgrade
of the boot system in NAND and may change some internal
parameters in an incompatible way.

It is potentially possible that u-boot can't start afterwards at all
and there are no signs of GTA04 activities (except on RS232),
even with fully charged battery. Since the charger is not yet fully
enabled the battery will drain and after a while the device is
really dead (but can be reanimated).

We have not yet worked out a complete cure, but for a first
step to avoid problems:

after downloading and unpacking of

	qtmoko-fat-v48.tar.gz

you should delete these files from the FAT partition:

	boot/boot.scr
	boot/x-load.flash
	boot/u-boot.bin

And, you can ignore the hints about special formatting almost
completely. Just make sure the first partition is FAT formatted
and QtMoko is installed on the second EXT formatted partition.

The special formatting is nowadays only needed in one case:
if the NAND flash is completely erased (i.e. no x-load.flash)
and everything must boot from SD.

The recommended way to flash an empty (erased) NAND is to
use the latest stable hw-validation image.

After the first sucessful flashing of the NAND (done now in the
factory together with the hardware test), only the bootargs.scr,
kernel and root file system need to come from SD card.

Nikolaus



More information about the Gta04-owner mailing list