[Gta04-owner] Hints for installing QtMoko on recently delivered GTA04 boards

Mark Müller markmueller86 at gmail.com
Sat Oct 27 14:07:01 CEST 2012


Hi Nikolaus,

since some weeks I'm the proud owner of a GTA04 and yesterday my new 
microSD card arrived as well. So I tried to install QtMoko -
I should have read this post before starting to install it yesterday. 
This would have saved me some time as I ended up restoring u-boot in 
NAND from SD card with a "flash_eraseall /dev/mtd2".

Here's a short description of what happened (with my interpretations - 
don't know if they are accurate):

I followed the instructions at

             http://sourceforge.net/projects/qtmoko/files/GTA04/

Trying to boot from SD card after that, I ended up in a reboot loop 
(u-boot menu, then splash screen, no kernel output, reboot) and trying 
to boot from NAND didn't work either (ending up in showing the kernel 
tux, then freezing). As I haven't got a RS232 adapter cable, I couldn't 
debug the boot sequence any further.

After that, I made an SD card with Debian/LXDE root file system from 
unstable and forced a NAND reflash from SD card (and installed the 
system in NAND with the flash-nand script). After that, I could boot 
from SD again. But I could not get QtMoko to boot until now.

The qtmoko-fat-v48.tar.gz has vanished from the download section of 
QtMoko - which is a good thing to prevent problems for new users (as 
me). And the README has been updated. Following the new instruction 
while keeping the actually installed boot files from the debian root 
file system I end up in a reboot loop again (as described above).

Am I doing something wrong? Are there instructions for how to install 
QtMoko from scratch that are known to work with the currently delivered 
batch of GTA04?

- Mark


On 25.10.2012 15:14, Dr. H. Nikolaus Schaller wrote:
> Hi,
>
> it appears we have found a potential source of issues when
> you get a recently new GTA04 with preinstalled Debian/LXDE
> image and then install QtMoko following these instructions:
>
> 	http://sourceforge.net/projects/qtmoko/files/GTA04/
>
> The problem is that qtmoko-fat-v48.tar.gz contains some
> older variant of u-boot and boot.scr and this may be executed
> when starting QtMoko from SD. This may result in a downgrade
> of the boot system in NAND and may change some internal
> parameters in an incompatible way.
>
> It is potentially possible that u-boot can't start afterwards at all
> and there are no signs of GTA04 activities (except on RS232),
> even with fully charged battery. Since the charger is not yet fully
> enabled the battery will drain and after a while the device is
> really dead (but can be reanimated).
>
> We have not yet worked out a complete cure, but for a first
> step to avoid problems:
>
> after downloading and unpacking of
>
> 	qtmoko-fat-v48.tar.gz
>
> you should delete these files from the FAT partition:
>
> 	boot/boot.scr
> 	boot/x-load.flash
> 	boot/u-boot.bin
>
> And, you can ignore the hints about special formatting almost
> completely. Just make sure the first partition is FAT formatted
> and QtMoko is installed on the second EXT formatted partition.
>
> The special formatting is nowadays only needed in one case:
> if the NAND flash is completely erased (i.e. no x-load.flash)
> and everything must boot from SD.
>
> The recommended way to flash an empty (erased) NAND is to
> use the latest stable hw-validation image.
>
> After the first sucessful flashing of the NAND (done now in the
> factory together with the hardware test), only the bootargs.scr,
> kernel and root file system need to come from SD card.
>
> Nikolaus
>
> _______________________________________________
> Gta04-owner mailing list
> Gta04-owner at goldelico.com
> http://lists.goldelico.com/mailman/listinfo/gta04-owner
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20121027/8482d9d6/attachment.html>


More information about the Gta04-owner mailing list