[Gta04-owner] Newbie alert: GTA04 starting issues

Sam Muirhead sam at yearofopensource.net
Tue Oct 23 17:56:17 CEST 2012

/	Hi Sam,
//	Am 23.10.2012 um 15:48 schrieb Sam Muirhead:
	>//  		>> I then inserted the SD card and tried to boot the GTA04. (not plugged
//  	//>	//	>> into USB)//
//	>//  		>> It didn't boot, there was no light from the power button, no other signs
//	>//  		>> of life.
//	>//  	>The last case "It didn't boot" means: not the bootloader either, after
//	>//  	>replacing the uSD?
//	>//  
//	>//  Not the bootloader either. With or without SD card, nothing happens when I try to power on.
//	What could have happened is that the contents of the NAND flash have been changed in a way that prevents booting.
	This means that X-Loader starts and loads U-Boot but U-Boot hangs before doing anything useful (e.g. switching on the display, blinking LEDs etc.).
	Therefore the device appears to be dead but it is just not coming beyond the point of showing any signs of activity.
	The problem is that the device isn't charging any more (except trickle charge) in this situation. I.e. battery drains and will not get full again. So
	after a while the battery is deeply discharged that even X-Loader does not start any more.
	But you can not see a difference from outside.
//	>//  I've checked my logs and had been getting the same message up until I tried booting it with the SD card.
//	>//  Since then there has been no recognition of the device at all, no 'new device' mentions.
//	This supports my theory stated above. U-Boot is responsible for initializing the USB interface.
//	>//  		>> So am I right in saying that I have a flat battery that won't charge?	
//	>//  		>> Or have I missed something important along the way?
//	>//  	>It is what Benjamin wrote: keep it connected, it will trickle-charge for quite
//	>//  	>a while, than start flashing the screen on and off, until it accumulates
//	>//  	>enough charge to reach the bootloader screen.
//	>//  
//	>//  I kept it connected yesterday, checking on it, and even leaving it connected overnight had no effect. It still won't power on.
	Recently I have received one device back that if I remember correctly was in the same state.
	I wasn't able to find out how it came into it, i.e. could not reproduce it or develop some countermeasures.

	The solution was to connect a RS232 cable and inspect the console messages. U-Boot did
	show some error messages but I could erase the U-Boot environment. After restart it worked
	fine again.

	Do you have access to such a cable? Or someone nearby can help you?/

Thanks for your help Nikolaus - I don't have access to an RS232 cable but I'm based in Berlin, is there anyone on the list who lives here and can help me out?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20121023/aea622ef/attachment-0001.html>

More information about the Gta04-owner mailing list