[Gta04-owner] Newbie alert: GTA04 starting issues

Dr. H. Nikolaus Schaller hns at goldelico.com
Tue Oct 23 16:49:40 CEST 2012


Hi Sam,

Am 23.10.2012 um 15:48 schrieb Sam Muirhead:

> 		>> I then inserted the SD card and tried to boot the GTA04. (not plugged
> 		>> into USB)
> 		>> The gta04 init bootloader screen appeared, and I tried to select the SD
> 		>> card, but nothing happened. no response, no sound, no visible change.
> 		>> I waited for one minute or so, then tried selecting NAND, just to see if
> 		>> it would do anything - still no change.
> 		>> I removed the battery, removed the SD card, replaced the battery and
> 		>> tried to just boot to lxde again.
> 		>> It didn't boot, there was no light from the power button, no other signs
> 		>> of life.
> 	>The last case "It didn't boot" means: not the bootloader either, after 
> 	>replacing the uSD? 
> 
> Not the bootloader either. With or without SD card, nothing happens when I try to power on.
What could have happened is that the contents of the NAND flash have been changed in a way that prevents booting.
This means that X-Loader starts and loads U-Boot but U-Boot hangs before doing anything useful (e.g. switching on the display, blinking LEDs etc.).

Therefore the device appears to be dead but it is just not coming beyond the point of showing any signs of activity.

The problem is that the device isn't charging any more (except trickle charge) in this situation. I.e. battery drains and will not get full again. So
after a while the battery is deeply discharged that even X-Loader does not start any more.

But you can not see a difference from outside.
> 
> 		>> -It was around this point that I read something saying the battery
> 		>> should be fully charged when installing an OS - I don't know how much
> 		>> charge was on the battery when I started, but it took me a long time
> 		>> organising the SD card so it may have been low by the time I tried to
> 		>> boot it.
> 	>I expect the phone being connected to your system via USB, while working on 
> 	>the uSD, or was it just lying around? As long as it keeps charging, USB 
> 	>provides enough power to run the phone and charge the battery.
> 
> It was not connected via USB the whole time, but it was only on for maximum 15 minutes since receiving the phone. 
> 
> 		>> Previously when plugged in via USB I at least had a notification that a
> 		>> wired network was active, but now there is no sign of a USB device being
> 		>> plugged in (at least I don't think there is). I'm running ubuntu 12.04
> 		>> on a Macbook Pro:
> 	>This is what tail -f /var/log/messages tells while turning on and showing the 
> 	>bootloader screen:
> 	>Oct 22 21:38:31 tp kernel: [345675.170991] usb 1-1.2: new full-speed USB 
> 	>device number 7 using ehci_hcd
> 
> I've checked my logs and had been getting the same message up until I tried booting it with the SD card. 
> Since then there has been no recognition of the device at all, no 'new device' mentions.  
This supports my theory stated above. U-Boot is responsible for initializing the USB interface.
> 
> 		>> So am I right in saying that I have a flat battery that won't charge?
> 		>> Or have I missed something important along the way?
> 	>It is what Benjamin wrote: keep it connected, it will trickle-charge for quite 
> 	>a while, than start flashing the screen on and off, until it accumulates 
> 	>enough charge to reach the bootloader screen. 
> 
> I kept it connected yesterday, checking on it, and even leaving it connected overnight had no effect. It still won't power on.
>  
> 	>If I recall correctly, the bootloader screen got enough intelligence to ask 
> 	>for a higher current (and charge faster). I'm not sure about that anymore 
> 	>though (it was in Radeks bootscreen documentation, but I can't find it at the 
> 	>moment).
> 
> 		>> Any suggestions for the next step I should try, or is there any further
> 		>> information I should supply?
> 	>Maybe one more thing: do you have an Openmoko charger, or another high(er) 
> 	>power charger? That will charge your battery faster than a USB port of course, 
> 	>but besides that, the powermanagement chip seems quite picky about the current 
> 	>it receives from the host. Alexander has given a list of creative ways of 
> 	>discharging the battery (which I could not find eiter, but I found another 
> 	>more to the point discussion about power at boot up: 
> 	>http://lists.goldelico.com/pipermail/gta04-owner/2011-November/000659.html
> 
> I don't have an Openmoko charger or any other kind of charger - just a USB cable. 
That should be sufficient to charge. The Openmoko charger has no real benefits unless you want to charge with WLAN and UMTS enabled and CPU on full power.
> Where can I get an Openmoko charger?
> 
> 	>Good luck!
> 
> Thanks for your help!

Recently I have received one device back that if I remember correctly was in the same state.
I wasn't able to find out how it came into it, i.e. could not reproduce it or develop some countermeasures.

The solution was to connect a RS232 cable and inspect the console messages. U-Boot did
show some error messages but I could erase the U-Boot environment. After restart it worked
fine again.

Do you have access to such a cable? Or someone nearby can help you?

BR,
Nikolaus


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20121023/7c6329cd/attachment.html>


More information about the Gta04-owner mailing list