[Gta04-owner] Another successful upgrade GTA02 -> GTA04 (except one little thing).

niels nift at maclisp.org
Sat Nov 24 01:02:36 CET 2012


Hi list

I received my GTA04 board several days ago, but yesterday I finally
had the time (and at last acquired a torx T6) to make the upgrade.

Following the fine manual it all went very well, except I managed to
break of the gps socket for the external antenna. I was gently putting
the new board in the case, but was to much focused on getting the usb
socket in place. Well I thought I was very gentle and felt it slided
nicely into place, then discovering that the gps antenna socket had
come loose. Oh bugger... 

I also "cheated" by ordering a new lcd screen with my GTA04
board. Judged that it would to difficult for me to remove the old one
from my GTA02 board without damaging something in the process. Plus
now I have a small computer with a screen for a potentially fun
project.

I downloaded qtmoko v49 (armel), installed on a sdcard and it booted
right away. yeah!

Good things:

1. Made one test phone call. Loud and clear sound from the
earpiece. No complaints from the other end. Perfect so far.

2. NeronGPS got a fix outside after 2-3 minutes. Great, uses the gps
all the time.

3. The GUI seemed "snappier", but not that much faster than my old
GTA02 (more on this later).


Less good things:

1. High cpu usage. 

Htop showed 60-100% cpu usage in total, thus it did not show any
processes that consumed that much. Except pulseaudio would pop up
often eating 100% cpu. So I guess that this is maybe why the GUI was
not as snappy as expected.

Also the case felt warmer than normal after some usage. Guess it is
expected if the cpu is running for full most of the time.

2. Bad antenna reception? 

I discovered mokofaen had red bars for gsm reception. I guess I knew
that, but after one day of usage, I have seen the red bars many times
during a normal day were I normally always had good reception. I even
disassembled it again to check that I had got the connection to the
antenna right (it was right as far as I know). Sometimes it would peak
to four full bars and the down to one bar (or red).

3. No charging. 

With high cpu and potential bad reception I quickly depleted my
battery. I tried to charge during the day from an usb port, as I
always did with my GTA02. But it wouldn't charge at all. I have tried
with different charges but no luck.

So now I have a completely emptied GTA02 battery. If I connect it to
an usb-charger It will boot up, powerbutton glows red, then green and
red again, but after seconds it goes completely dark, and it doesn't
seem to do any charging at all.

If I leave the charge connected, it seemingly random starts to boot,
powerbutton lights up... some seconds later it turns of again.

Will try to leave it in the charger overnight.

-- 
niels


More information about the Gta04-owner mailing list