[Gta04-owner] bootargs.scr - how does it work?

Dr. H. Nikolaus Schaller hns at goldelico.com
Thu Nov 22 17:30:38 CET 2012


Am 22.11.2012 um 17:18 schrieb Radek Polak:

> On Thursday, November 22, 2012 02:35:19 PM Dr. H. Nikolaus Schaller wrote:
> 
>>> Could you please share the command?
>> 
>> mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n 'Boot Script' -d
>> boot.txt boot.scr
>> 
>> should do the trick.
> 
> Thanks! It did it. But only partially.
> 
> I have uImage and bootargs.scr on the first FAT. This works perfectly. After 
> touching "SD 1" in uboot menu QtMoko starts and i can see my args in 
> /proc/cmdline.
> 
> But if i copy the same kernel and bootargs.scr to /boot on ext4 partition with 
> QtMoko on p2 and select "SD 2" the screen goes green for a second and NAND 
> kernel starts booting (i can see the tux logo).
> 
> Should i try ext2 or ext3 instead of ext4? Any ideas what can be wrong?

Yes, it tmay be possible that u-boot can't read ext4 correctly. I thought they are
backwards compatible but I don't know for sure.

But then it would not find the uImage and default to the one in NAND.
Ah, that may explain the symptom.

And it may be a compelling reason to keep gta04-init within QtMoko to boot
the kernel from ext4.

Question for further debugging:

did you delete the kernel from partition 1
in this test? If it exists it should finally be tried.

If it wasn't tried either, the SD card may be corrupt. I once had lost the
partition table completely and could only boot to NAND.

BR,
Nikolaus





More information about the Gta04-owner mailing list