[Gta04-owner] Amazing adventures with a brandnew GTA04...

Radek Polak psonek2 at seznam.cz
Thu Feb 9 14:10:18 CET 2012


On Thursday 09 February 2012 11:36:52 Sven Dyroff wrote:

> I'm completely new to Openmoko. Thanks to Golden Delicious on monday I
> received the brandnew GTA04A4. For 29 EUR I got a 16 GB Class 10
> Micro-SD-Card. Yesterday I put the brandnew QtMoko v39 on it and began to
> start. I think it can be useful for you if I tell you the adventures I
> then experienced...   ;-))

Welcome on the board ;-)

> Thanks to this mailinglist I already knew that it's not recommended to
> start without a SIM plugged in. So after passing the first pictures with
> touch calibrating and typing in PIN I looked a little bit around in the
> menues and then of course I wanted to explore if it's possible to phone
> with the phone. I typed in the number of my currently used mobile and the
> miracle happend that it really began to ring. Then I touched the cancel
> button because I didn't want to spend money in order to phone with myself.
> The GTA04A4 returned to the previous screen. But the other mobile
> continued to ring and to ring and to ring... In the end I stopped it by
> pressing the cancel button on it, too...  ;-))
> 
> Then I tried to call the GTA04A4. It really began to ring. Exactly once.
> Then it showed "1 missed call". Then it rang again. Then it showed a
> second message "1 missed call". Then it rang again... In the end I pressed
> the cancel button on my mobile...   ;-))

I hit the same problem too. Unfortunately i can't reproduce it yet. I tried 
your steps but it worked this time ;-( It would be really nice if you could 
give exact steps which reproduce it.

> After that I explored the menues of telephone contacts and calls and so on
> more deeply. I wanted to remove the "missed call"-messages. But where on
> earth is the "delete"-button? I tried everything, but the messages are
> still there, just jamming the list...   :-(

On the main screen just pres the "missed calls" icon.

> OK, I became more brave. I explored the telephone settings, searching for
> the possibility to enter my APN. After little time I found it. I got the
> field "APN" and a blinking cursor.

GTA04 can access 3G internet, but it's not using PPP as Freerunner. We need 
special 3G internet plugin for GTA04 UMTS. But it already works from command 
line, you can read about it here [1].

> But how on earth should I enter letters
> with a touch without showing a keyboard? I tried and found a menu with the
> entry "change input method" and with that I got a keyboard shown. It
> showed only letters. How should I enter the period with that, needed for
> the APN? No chance! No period!   :-(    I thought that all the others of
> you (the GTA04-community) also must have managed to enter their APN and so
> I began a struggle with the GTA04 and after some time and only by accident
> I got another keyboard. It was such microscopic little that it was
> impossible to decode the meaning of some keys, but at least it offered me
> a period. So I won the fight! I succeded to enter the two periods for the
> APN.    \o/  \o/  \o/

I agree that Input methods in QtMoko are really crappy. I have some ideas but 
i didnt have time to implement it yet - there are now more important things...

> Of course my next step was to search for a browser. But in this case, the
> GTA04 won the fight. I searched and searched and searched, but couldn't
> find a browser. Is there one already included in QtMoko v39 ?

Arora is the web browser - it's first icon in Application list.

> Second question: On my way to find the possibility the APN I accidently
> touched the wrong button. Instead of "GPRS" I activated "Ethernet" (the
> menu entry once above). But where's the possibility to remove this entry
> again? No possibility to delete it any more...  :-(

You can remove the entry only if it's not active. You might need to do this 
command in terminal:

	ifconfig usb0 down

then back to Settings->Internet, "Stop" from context menu and "Delete" from 
context menu.
 
> I played some more with some features I found randomly and more and more I
> got the impression that it's really nice and lovely. Yes I already really
> like it! And while you're fixing lots of crazy bugs (yes, when ordering
> the GTA04 from Golden Delicious I've been aware that this will be my
> ticket for entering a mine field...) I only have some more hopefully
> simple questions:
> 
> - How can I supply my own ring tones?

I discovered it 2 days ago after 3 years of using QtMoko ;-) Go to Settings-
>Profiles, select "General" and choose "Edit" from context menu. Go to tab 
"Tones" and press the button next to "Tone" label.

If you want your own tones you have to copy them to the phone. The media 
system will try to find them in /home/root/Documents or /media/card/Documents. 
They should be visible then under the documents icon (the right bottom icon in 
Main menu). You can select "Rescan System" to refresh the document list.

By default QtMoko can play wav and ogg files. If you install codecs 
(Applications->More apps) you can also play mp3.

> - How can I supply a "video ring tone"?

Same way as ringtone, but i am not sure if it works - i never tried it.

> - How can I use IrDA if I don't want to open the case in order to access
> UART3 with a terminal from my Ubuntu 11.04 PC?

You can use USB networking [1] for accessing the phone. GTA04 has after boot 
by default usb0 network which has ip address 192.168.0.202. If you connect the 
phone and PC with USB cable you will see in dmesg on PC:

	usb0: register 'cdc_ether' at usb-0000:00:1a.0-1.2, CDC Ethernet Device, 	
fa:3f:70:fc:3f:2f

if you do:

	ifconfig usb0 192.168.0.200
	ping 192.168.0.202

it should ping and

	ssh root at 192.168.0.202

should give you shell. If you want internet on the phone do this:

	iptables -A POSTROUTING -t nat -j MASQUERADE -s 192.168.0.0/24
	echo 1 > /proc/sys/net/ipv4/ip_forward
	iptables -P FORWARD ACCEPT


> - How can I switch off the display? It doesn't make any sence that it's
> constantly on even when not being used for hours?

By locking the main screen (after 10s it should dim). You can set intervals 
and enable suspend in Settings->Power management.

> Best regards,
>    Sven

Thanks for nice summary about your experience and good luck.

Regards

Radek


[1] http://lists.goldelico.com/pipermail/gta04-owner/2012-January/001361.html
[2] http://wiki.openmoko.org/wiki/USB_Networking


More information about the Gta04-owner mailing list