[Gta04-owner] Just two boring user questions

Dr. H. Nikolaus Schaller hns at goldelico.com
Tue Feb 7 20:16:37 CET 2012


Am 07.02.2012 um 20:08 schrieb tango at riseup.net:

> Hi everybody,
> I just recieved my new GTA04, right now some questions arise.
> maybe stupid but I didn't find the answer on gta04.org or qtmoko.
> 
> 1.) I followed the rootfs-guide
> (http://projects.goldelico.com/p/gta04-rootfs/)
> and LXDE started up without any problems. Fast and fine !
> But LXDE is "just proof-of-concept-Linux" without phone capabilities, or
> am I wrong ?

Yes, that is right. It is to test and demonstrate the hardware.

> So I tried to install illume and/or zhone, but that didn't work (with
> the default repositories).

I think they need a lot of manual configuration to make them work.

> 2) Then I tried to install QTMoko-gta04-v38. I followed the instructions
> on sourceforge and just left the /boot files from the first LXDE-install
> in place (MLO etc) replacing only uimage and configs. After that i
> deleted everything on the EXT-partition and un-tared the
> qtmoko-archive. 

I also don't have much experience with QtMoko, but I read the
instructions in the way that you just have to build the partitions,
install MLO, uBoot etc on the FAT partition.

And then extract the QtMoko. I.e. you don't need to install
the LXDE before. This may leave some files you don't need.

What may make the main difference is to copy the correct
kernel. I.e., copy the 3.2-QtMoko kernel from /boot on the EXT3
to the root of the FAT partition.

It looks to me as you may have booted the LXDE-kernel.

> Well, it started up but after date/time-configuration it always freezes
> with the "gray-clock-of-death" ;-).

BR,
Nikolaus


More information about the Gta04-owner mailing list