[Letux-kernel] mmc1 errors on Beaglebone Black since 5.17-rc3

Jean Rene Dawin jdawin at math.uni-bielefeld.de
Tue Feb 15 10:41:07 CET 2022


Hi,

since kernel 5.17-rc1 I noticed slower emmc performance on Beaglebone
Black, but didn't check the logs.
When I tried to run 5.17.0-rc3-letux+ it booted fine, but during IO
traffic there were messages like

[  662.529584] mmc1: error -110 doing runtime resume
[  669.293590] mmc1: Card stuck being busy! __mmc_poll_for_busy

[  739.076072] mmc1: Timeout waiting for hardware interrupt.
[  739.145676] mmc1: sdhci: ============ SDHCI REGISTER DUMP ===========
[  739.231053] mmc1: sdhci: Sys addr:  0x00000000 | Version:  0x00003101
[  739.316472] mmc1: sdhci: Blk size:  0x00000200 | Blk cnt:  0x00000400
[  739.401937] mmc1: sdhci: Argument:  0x00342d30 | Trn mode: 0x00000023
[  739.487439] mmc1: sdhci: Present:   0x01f70000 | Host ctl: 0x00000000
[  739.573007] mmc1: sdhci: Power:     0x0000000f | Blk gap:  0x00000000
[  739.658609] mmc1: sdhci: Wake-up:   0x00000000 | Clock:    0x00003c07
[  739.744224] mmc1: sdhci: Timeout:   0x00000007 | Int stat: 0x00000002
[  739.829896] mmc1: sdhci: Int enab:  0x027f000b | Sig enab: 0x027f000b
[  739.915623] mmc1: sdhci: ACmd stat: 0x00000000 | Slot int: 0x00000001
[  740.001394] mmc1: sdhci: Caps:      0x07e10080 | Caps_1:   0x00000000
[  740.087208] mmc1: sdhci: Cmd:       0x0000193a | Max curr: 0x00000000
[  740.173051] mmc1: sdhci: Resp[0]:   0x00000900 | Resp[1]:  0x00000000
[  740.258928] mmc1: sdhci: Resp[2]:   0x00000000 | Resp[3]:  0x00000000
[  740.344854] mmc1: sdhci: Host ctl2: 0x00000000
[  740.402796] mmc1: sdhci: ============================================

and finally IO errors and a corrupted filesystem.

5.17.0-rc4-letux+ shows the same behaviour.

Has anyone seen this, too?

Regards,
Jean Rene Dawin


More information about the Letux-kernel mailing list