[Letux-kernel] Building bootable image for the CI20

H. Nikolaus Schaller hns at goldelico.com
Fri Nov 12 10:35:58 CET 2021


Hi Lucas,

> Am 12.11.2021 um 01:04 schrieb Lucas Fryzek <lucas.fryzek at hazeco.xyz>:
> 
> Hello,
> 
> I'm trying to setup a letux image to run on the Creator CI20. I saw that you have a "makesd" utility, and I've tried that with a number of different command line options but I can't get an image that works on my CI20 board. Here are some different commands I've tried
> 
>  59 ./makesd ci20 -r lxde
>  61 ./makesd -v latest ci20 -r lxde
>  70 ./makesd -v latest ci20 -r minimal
> 
> None of these seems to work and all fail with a similar error. Below[1] is a link to the output from the serial console on boot. It seems that the network interfaces fail to raise, and the it goes into maintenance mode.
> 
> Have the prebuilt rootfs and kernel been tested on the CI20? Is there a known working process I can follow to get an image booting and running on the CI20 to begin doing my work?

thanks for trying! It looks as if the -v latest installs the "latest" debian rootfs which is Bullseye. This may have some config issues.

So please try:

> ./makesd -v latest -vr stable ci20 -r minimal

This means "latest" for everything but "stable" for the root file system. This should be Debian Stretch.

Alternatively you can replace the -r minimal by some -r http: from http://download.goldelico.com/letux-debian-rootfs/?C=M;O=D

e.g. 

> ./makesd -v latest -vr stable ci20 -r http://download.goldelico.com/letux-debian-rootfs/stretch-mipsel-minimal.tbz

Please let me know if that works.

BR and thanks for trying!

Nikolaus



More information about the Letux-kernel mailing list