[Letux-kernel] JZ4730 kernel support

Paul Boddie paul at boddie.org.uk
Mon Oct 21 13:01:19 CEST 2019


On Monday 21. October 2019 09.37.32 H. Nikolaus Schaller wrote:
> > Am 19.10.2019 um 13:50 schrieb Paul Boddie <paul at boddie.org.uk>:
> > 
> > commit 48beba8932f2d296cd0a031003cf295096c9dc40 (grafted,
> > origin/letux/jz4730)
> Yes, that did work.

Great!

> > There should be five patches in this bundle, three of which you will have
> > seen before. Sorry not to be able to prepare these in a nicer way, but
> > git generally isn't happy running properly on my hardware with these
> > repositories.
> No problem. A patch set sent like this just needs knowledge about the
> merge base - if the merge base itself changes. This seems to be the cas
> with -rc for the ingenic subtree...

Is the history being rewritten or something? That is the only explanation for 
why patches might suddenly not be applicable, at least if I am making them for 
the right branch.

> > Maybe preparing them all separately instead of in combined form is better.
> > I've attached an archive to this message containing the individual
> > patches.
> 
> That doesn't make a big difference - except that some patches may apply
> cleanly while others still fail.

Yes, the intention is to permit partial failure rather than always experience 
complete failure.

> But what is your git repo problem? I have not seen a problem cloning it on
> quite different systems: e.g. macOS or a RasPi 3B+ with a 200GB µSD card
> running ifself with LetuxOS.

I did look at my complaints about this in the archives, but I don't think 
there was a successful resolution. You did write something about this, but I 
didn't find that message.

It is possible that some tuning is needed with git, given that I am using 
machines with only 1GB RAM, but as I noted before, the advice about such 
things is all over the place: people suggest changing some settings, other 
people claimed that it worked for them, still other people claim that it 
didn't work but something else did. And so on.

> And maybe it would be good if you would become "Happy Crew" member of the
> letux kernel team and get write-access to the repo:
> 
> http://projects.goldelico.com/p/gta04-kernel/
> 
> I have already added you. To get ssh write access you should add your
> key to the user-config page and then I have to run a script to copy it
> to the ssh/git daemon's permission files.

I did manage to submit patches to the gta04-kernel before now. Navigating 
branches was slow, but it did work, more or less.

My workaround currently involves a shallow clone of the appropriate branch in 
the letux-kernel repository, which is the one piece of advice I found that 
actually seems to work for people in my situation. Unfortunately, switching 
branches seems to cause git to want to fetch all the history, even though the 
(awful) man pages suggest that this shouldn't happen for shallow clones. And 
it is this history fetching that leads to the "index pack failed" error.

I'll try and think of other approaches, but I don't have so many ideas at the 
moment. Then again, I don't think there are so many other changes to be made 
at the moment, either.

Paul


More information about the Letux-kernel mailing list