[Letux-kernel] LetuxOS: kernel: letux-5.5-rc1

H. Nikolaus Schaller hns at goldelico.com
Wed Dec 11 17:03:35 CET 2019


> Am 10.12.2019 um 22:05 schrieb Andreas Kemnade <andreas at kemnade.info>:
> 
> On Tue, 10 Dec 2019 21:51:52 +0100
> "H. Nikolaus Schaller" <hns at goldelico.com> wrote:
> 
>>> Am 10.12.2019 um 20:57 schrieb H. Nikolaus Schaller <hns at goldelico.com>:
>>> 
>>> 
>>>> Am 10.12.2019 um 19:01 schrieb H. Nikolaus Schaller <hns at goldelico.com>:
>>>> 
>>>> Next, I'll try to build with your defconfig.  
>> 
>> I have simply copied it to arch/arm/configs/letux_defconfig. Then it will
>> be taken by my scripts.
>> 
>>> 
>>> Hm:
>>> 
>>> LD [M]  lib/crypto/libdes.o - due to: lib/crypto/des.o
>>> Building modules, stage 2.
>>> MODPOST 436 modules - due to target is PHONY
>>> ERROR: "input_unregister_polled_device" [drivers/iio/industrialio.ko] undefined!
>>> ERROR: "input_register_polled_device" [drivers/iio/industrialio.ko] undefined!
>>> ERROR: "devm_input_allocate_polled_device" [drivers/iio/industrialio.ko] undefined!
>>> make[3]: *** [__modpost] Error 1
>>> make[2]: *** [modules] Error 2
>>> make[1]: *** [__build_one_by_one] Error 2
>>> make: *** [sub-make] Error 2
>>> 
>>> $head->scratch()  
>> 
>> Ok, I have disabled the IIO_INPUT_BRIDGE.
>> 
>> Now I can compile
>> ...
>> ...
>> ...
>> and it boots. Also without display. There is no td028ttec1 panel driver in
>> modprobe -c. Indeed, CONFIG_DRM_PANEL_TPO_TD028TTEC1=m is not in your config.
>> CONFIG_DRM_OMAP_PANEL_TPO_TD028TTEC1=m is but that does no longer exist in
>> v5.5-rc1.
>> 
> well, no need for that on the letux 3704.

Indeed... I think the missing panel is a secondary bug.

I think I have boiled it down to

CONFIG_ARCH_BCM=y or n

(or one of the subconfigs enabled by that).

Will need a clean test though.

BR,
Nikolaus



More information about the Letux-kernel mailing list