[Letux-kernel] Debugging 4.11-rc6 on GTA04

Andreas Kemnade andreas at kemnade.info
Tue Apr 11 19:49:08 CEST 2017


On Tue, 11 Apr 2017 15:36:32 +0200
"H. Nikolaus Schaller" <hns at goldelico.com> wrote:

> Hi Andreas,
> 
> > Am 11.04.2017 um 12:43 schrieb Andreas Kemnade <andreas at kemnade.info>:
> > 
> > On Mon, 10 Apr 2017 22:01:28 +0200
> > "H. Nikolaus Schaller" <hns at goldelico.com> wrote:
> > 
> >> 
> >>> Am 10.04.2017 um 20:13 schrieb H. Nikolaus Schaller <hns at goldelico.com>:
> >>> 
> >>> Hi,
> >>> I have found a little time to upgrade our tree to 4.11-rc6
> >>> and for the first time there were no kernel oops on the GTA04(A5)
> >>> until login.
> >>> 
> >>> Only the LCD is broken :(
> >>> 
> >>> On the Pyra the same kernel works well. So it seems to be
> >>> OMAP3 specific (maybe again some interference of the TILER
> >>> addition, but I can easily check by merging my 4.11-rc6
> >>> without TILER).
> >> 
> >> I have now built w/o TILER and for the first two boot attempts I had the
> >> same error. But the third one succeeded. This time I got
> > [...]
> >> 
> >> And the ethernet gadget was not loaded (initially). No VBUS event reported. But charger started charging.
> >> 
> >> After unplugging the USB cable I got:
> >> 
> >> root at letux:~# [  230.016326] musb-hdrc musb-hdrc.0.auto: VBUS_ERROR in b_idle (90, <VBusValid), retry #0, port1 00000100
> >> 
> >> And then:
> >> 
> >> [  237.857330] g_ether gadget: high-speed config #1: CDC Ethernet (ECM)
> >> [  238.624481] IPv6: ADDRCONF(NETDEV_CHANGE): usb0: link becomes ready
> >> 
> >> Otherwise I didn't see any significant issue.
> >> 
> >> So it looks as if we still have two bugs: one in musb and another one in TILER/crtc.
> >> 
> > Sounds like problems which can be bisected on mainline. I think I will
> > bisect this evening a bit. With musb, there is probably just another
> > enable/disable balancing problem which must be somehow worked around in
> > the glue layer or phy.
> 
> Good ideas!
> 
> But this gave me another idea... I have added a command line option to my
> merge script so that it ignores the mergefile. Then I can add a handful
> of our feature branches to be merged on top of letux-base.
> 
> With these ones, I could get it compiled and run on the GTA04A5 (of course missing sound,
> inverted touch etc.):
> 
> ./merge -p -nmf -- work/hns/letux/rootfs work/hns/dt/gta04 work/hns/dt/gta04a5 work/hns/mtd/onenand work/marek/generic-adc-battery work/hns/misc/w2sg-serdev
> 
> Result is at:
> 
> http://git.goldelico.com/?p=gta04-kernel.git;a=shortlog;h=refs/heads/letux-4.11-rc6%2Brootfs%2Bgta04%2Bgta04a5%2Bonenand%2Bgeneric-adc-battery%2Bw2sg-serdev
> 
> Interestingly our feature branches are not as independent as they should
> be... The generic adc battery is needed for some #include in the GTA04DT and
> GTA04A5 wants to modify a bluetooth node that comes through the w2sg-serdev
> branch.
> 
> Anyways, the important information is: with this minimum set of feature branches
> I have neither problems with musb nor display. So the issue is not coming from
> mainline...
> 
Well, I have just a white screen here with that. So, there is more...

AFAICR, the most important this
missing in twl4030_charger are the things to have detection working when
the stuff is loaded. So for mainline experiments, the idea would be to
build musb/twl stuff not as modules. And keep our device tree.

Regards,
Andreas
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <http://lists.goldelico.com/pipermail/letux-kernel/attachments/20170411/45cc2152/attachment.asc>


More information about the Letux-kernel mailing list