[Gta04-owner] Trying to flash U-Boot led to a bricked device

H. Nikolaus Schaller hns at goldelico.com
Sun Mar 11 12:30:16 CET 2018

Hi cnut,
sorry for not jumping into this earlier. Had too much to do with
seasonal illness...

> Am 11.03.2018 um 11:32 schrieb cnut <cnut at posteo.de>:
> Hello Andreas,
> after ./usb-start-uboot.sh and dfu-util did not show any reaction, I re-tried looking at dmesg - this time without success.
> I tried this on 2 different notebooks and a pc, each with two different USB cables (one of the cables did work with a gta02):
> 1) Remove battery, sim card, and sd card from the gta04
> 2) Press the aux button on the gta04. While holding the aux button plug the gta to the usb port to the pc / notebook. I tried this with 5, 15 and 30 seconds  before releasing the aux button.
> 3) Looked ad the output of dmesg.

I just tried this with a working GTA04:
* remove battery
* remove µSD card
* plug in USB cable to an USB port of an ARM based SBC (OMAP5EVM but should not matter)
* press AUX button
* insert battery to trigger boot (although USB power is there, it is limited to 100mA which is not enough to start the OMAP)
* look at dmesg of the host

This is what I got:

[  151.391281] usb 1-2.1: new high-speed USB device number 5 using ehci-omap
[  151.542367] usb 1-2.1: unable to get BOS descriptor
[  151.548622] usb 1-2.1: New USB device found, idVendor=0451, idProduct=d00e
[  151.555925] usb 1-2.1: New USB device strings: Mfr=33, Product=37, SerialNumber=0
[  151.563849] usb 1-2.1: Product: OMAP3630
[  151.567959] usb 1-2.1: Manufacturer: Texas Instruments

> I did not find anything like idVendor=0451, OMAP, Texas Instrurments.
> I charged the battery for ca. 2 hours in a gta02 to be sure that there is enough power, and put the battery in the gta04. I still do not get any reaction in dmesg or using dfu-util.
> The aux button itself ist at least pushable (I hear a small click).

Without AUX button there is no USB report (except that my GTA04 boots from NAND).

Also, inserting battery first (with or without AUX button) and then plugging the
cable doesn't show a signal but boots from NAND (and then there is no USB activity).

The reason is that the AUX button modifies the power-on boot sequence
from NAND -> USB -> UART -> MMC to USB -> UART -> MMC -> NAND

See: http://projects.goldelico.com/p/gta04-main/downloads/54/

Probably a wrong sequence of USB cable and battery insert makes the USB enumeration

> A small thing that confuses me:
> In the README file in spl-dfu-gta04a4.tar.gz is written, that for non root users the "dfu-gta04.rules has to be copied into /etc/udev/rules.d". There is no file dfu-gta04.rules.
> Nishanth Menon wrote the readme, so I am not sure if this the right mailing list to write about it.
> Any idea what how to proceed?
> Regards
> cnut
> On 03/07/2018 07:53 PM, Andreas Kemnade wrote:
>> On Wed, 7 Mar 2018 19:33:06 +0100
>> cnut <cnut at posteo.de> wrote:
>>> Thank you Andreas, for your detailed mail.
>>>  > If you boot with aux pressed...
>>> dmesg shows that the device is not dead.
>>>  > A serial cable would be helpful to find out.
>>> If you are talking about a JTAG serial cable: I do not have one. But I
>>> am interested in having a look how this works. If you have a link which
>>> cable is needed and how to use it, I am happy to gain a little bit more
>>> knowledge in this area.
>> Well, not a jtag cable, an ordinary serial rs232 console you use
>> programs like minicom with.

Yes, the RS232 serial console cable would be the easiest approach to look
what the device is doing/reporting. But if you don't have it, it does not help.

Do you by any chance know when you did last time flash the boot loader?

There might be something incompatible with old and latest versions we don't
know yet.

Maybe the u-boot environment of an old boot loader in NAND flash breaks
booting a new one and must be reset (which does not work if the device
does not boot).

In that case you could try to reflash or completely boot the old boot loader
from an µSD where the old boot loader is stored on.

We have an archive of all boot loader binaries and sources:




but without roughly knowing the version it is difficult to guess and write
instructions for preparing an µSD for that.

Ah, maybe the S/N of your device could help to find out the production

>>>  > 1. clone my omap-utils fork...
>>>  > 2. do a make
>> [...]
>>> /bin/sh: 1: pkg-config: not found
>>> src/pusb.c:45:20: fatal error: libusb.h: No such file or directory
>>>   #include <libusb.h>
>>>                      ^
>> apt-get install pkg-config
>> Regards,
>> Andreas


More information about the Gta04-owner mailing list