[Gta04-owner] Trying to flash U-Boot led to a bricked device

cnut cnut at posteo.de
Sun Mar 11 11:32:22 CET 2018

Hello Andreas,

after ./usb-start-uboot.sh and dfu-util did not show any reaction, I 
re-tried looking at dmesg - this time without success.

I tried this on 2 different notebooks and a pc, each with two different 
USB cables (one of the cables did work with a gta02):
1) Remove battery, sim card, and sd card from the gta04
2) Press the aux button on the gta04. While holding the aux button plug 
the gta to the usb port to the pc / notebook. I tried this with 5, 15 
and 30 seconds  before releasing the aux button.
3) Looked ad the output of dmesg.

I did not find anything like idVendor=0451, OMAP, Texas Instrurments.

I charged the battery for ca. 2 hours in a gta02 to be sure that there 
is enough power, and put the battery in the gta04. I still do not get 
any reaction in dmesg or using dfu-util.

The aux button itself ist at least pushable (I hear a small click).

A small thing that confuses me:
In the README file in spl-dfu-gta04a4.tar.gz is written, that for non 
root users the "dfu-gta04.rules has to be copied into 
/etc/udev/rules.d". There is no file dfu-gta04.rules.
Nishanth Menon wrote the readme, so I am not sure if this the right 
mailing list to write about it.

Any idea what how to proceed?


On 03/07/2018 07:53 PM, Andreas Kemnade wrote:
> On Wed, 7 Mar 2018 19:33:06 +0100
> cnut <cnut at posteo.de> wrote:
>> Thank you Andreas, for your detailed mail.
>>   > If you boot with aux pressed...
>> dmesg shows that the device is not dead.
>>   > A serial cable would be helpful to find out.
>> If you are talking about a JTAG serial cable: I do not have one. But I
>> am interested in having a look how this works. If you have a link which
>> cable is needed and how to use it, I am happy to gain a little bit more
>> knowledge in this area.
> Well, not a jtag cable, an ordinary serial rs232 console you use
> programs like minicom with.
>>   > 1. clone my omap-utils fork...
>>   > 2. do a make
> [...]
>> /bin/sh: 1: pkg-config: not found
>> src/pusb.c:45:20: fatal error: libusb.h: No such file or directory
>>    #include <libusb.h>
>>                       ^
> apt-get install pkg-config
> Regards,
> Andreas
> _______________________________________________
> Gta04-owner mailing list
> Gta04-owner at goldelico.com
> http://lists.goldelico.com/mailman/listinfo.cgi/gta04-owner

More information about the Gta04-owner mailing list