[Gta04-owner] Trying to flash U-Boot led to a bricked device

Andreas Kemnade andreas at kemnade.info
Sun Mar 4 00:15:28 CET 2018


first measure, take a deep breath, I do not believe your device is
If you boot with aux pressed (*before* powering on the device) and have
it connected to the computer, do you still see lines like that in
kern.log or dmesg:
usb 1-2.4: New USB device found, idVendor=0451, idProduct=d00e
usb 1-2.4: New USB device strings: Mfr=33, Product=37, SerialNumber=0
usb 1-2.4: Product: OMAP3630
usb 1-2.4: Manufacturer: Texas Instruments

You have still good chances to do something.

On Sat, 3 Mar 2018 22:09:28 +0100
cnut <cnut at posteo.de> wrote:

> Hello,
> I tried to flash U-Boot and now my gta04 does not react any more. If 
> anybody has an idea how to unbrick the device or can tell me what I did 
> wrong, please let me know.
> Here is a description of what I did:
> Using "makesd gta04 debian", I wrote data on a sd card. The sd card was 
> put into the gta04. After reading in this post [1] how to flash U-Boot, 
> and after several attemps [2] the red flashing screen appeared. The red 
> color flashed only for some seconds. After that the gta04 screen showed 
> a picture which looked like a tv showing a dead channel. The dead 
> channel picture did not go away for some time, so I powered off the 
> gta04 by pressing the power button for some seconds.

Well, a serial boot log would be interesting. Somehow the upgrade
process is done half.

> Now I am not able to power on the device. I tried various combinations 
> of pressing the aux and power button, with and without an sd card (with 
> a 4 year old working qtmoko) in the device.
> The battery is not empty. I use a gta04a4.
So inserting the freshly-generated sd card for a second time does not
So we have at least two possibilities:
1) sd card contact problems
2) uboot environment is trashed.

A serial cable would be helpful to find out.
Or simply try another sd card.

If that fails and the above usb messages are appearing:
1. clone my omap-utils fork:
2. do a make
    and sudo make install there (will need libusb-1.0-0-dev)
3. sudo apt-get install dfu-util

4. wget https://misc.andi.de1.cc/spl-dfu-gta04a4.tar.gz
5. tar -zxvf spl-dfu-gta04a4.tar.gz
6. cd spl-dfu
7. sudo ./usb-start-uboot.sh
8. remove battery from your gta04.
9. attach it with usb.
10. press and hold aux button
11. insert battery
12. tell me what happend

Expected: u-boot is successfully started and waits for usb input
lcd stays black
But you should see in
sudo dfu-util -l
dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2016 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to http://sourceforge.net/p/dfu-util/tickets/

Found DFU: [0451:d022] ver=0215, devnum=95, cfg=1, intf=0, path="1-2", alt=4, name="bootscript", serial="UNKNOWN"
Found DFU: [0451:d022] ver=0215, devnum=95, cfg=1, intf=0, path="1-2", alt=3, name="script", serial="UNKNOWN"
Found DFU: [0451:d022] ver=0215, devnum=95, cfg=1, intf=0, path="1-2", alt=2, name="rd", serial="UNKNOWN"
Found DFU: [0451:d022] ver=0215, devnum=95, cfg=1, intf=0, path="1-2", alt=1, name="fdt", serial="UNKNOWN"
Found DFU: [0451:d022] ver=0215, devnum=95, cfg=1, intf=0, path="1-2", alt=0, name="kernel", serial="UNKNOWN"

If that works, your gta04 should also be charging (if your cable is not
too weak

Then there is the script called 
usb-flash-uboot-gta04.sh in that directory which can write a fresh uboot into your nand flash.
./usb-flash-uboot-gta04.sh nand /path/to/uboot-files

should contain MLO, u-boot.img, boot.scr, splash.rgb16z, menu.rgb16z

you can get them e.g. from here:


PS: the source of that spl-dfu stuff is commit
of the gta04 uboot
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20180304/4bcda1b4/attachment.asc>

More information about the Gta04-owner mailing list