[Gta04-owner] re-installing qtmoko broken?

H. Nikolaus Schaller hns at goldelico.com
Wed Feb 8 06:32:47 CET 2017


Hi Erich,

> Am 07.02.2017 um 22:49 schrieb jake42 <jake42 at rommel.stw.uni-erlangen.de>:
> 
> On 07.02.2017 21:40, Erich Wälde wrote:
>> Hello all,
>> 
>> my trusty gta04/qtmoko has given up a few weeks ago (probably
>> the content of the sdcard corrupted). I tried to reinstall using
>> instructions found here:
>> http://projects.goldelico.com/p/gta04-makesd/
>> 
>> 
>> DEV=/dev/sdd ./makesd qtmoko
>> 
>> failed first due to a download failure, fixed by s/letux/gta04/
>> on one line in the script makesd:
>> 
>> -     qtmoko ) P="http://download.goldelico.com/letux-qtmoko/$VARIANT.tbz" ;;
>> +     qtmoko ) P="http://download.goldelico.com/gta04-qtmoko/$VARIANT.tbz" ;;
>> 
>> There seems to be another error later fixed by calling the
>> script differently
>> 
>> - DEV=/dev/sdd ./makesd -f ext4 -r qtmoko -d all    -k latest
>> + DEV=/dev/sdd ./makesd -f ext4 -r qtmoko -d latest -k latest
>> 
>> This downloads everything needed and unpacks the system onto
>> sdcard.
>> 
>> HOWEVER, this results in an unbootable system. The screen turns
>> black after the u-boot boot loader (white screen and green LED)
>> and does not change for at least 15 Minutes.
>> 
>> 
>> So, the question is: what else to look for? Could it be that
>> there is a bootloader update needed or something such? Or a
>> u-boot script file???
>> 
>> I can provide an install log, if that helps.
>> 
>> 
>> I managed to install replicant-4.2 but find it unusable due to
>> its power consumption: my batteries (ca. at 80%) are completely
>> drained in less than 8 hours.
>> 
>> 
>> Ideas?
>> Thank you!
>> 
>> Erich
>> 
> 
> Hi Erich,
> 
> I'm using the image from
> https://sourceforge.net/projects/qtmoko/files/GTA04/qtmoko-debian-gta04-v56-armhf.tar.gz/download
> (as radek suggests)
> 
> I extracted the tar.gz to an ext4 partition on my sdcard and it boots happily from it with the usual bootloader in nand.

Yes,
this is certainly the best approach.

The makesd script would mix the qtmoko rootfs with latest kernels, but multiple APIs and configs have become incompatible. Therefore you get an unbootable system. QtMoko runs best with the 3.7 kernel.

Unfortunately we have not had much progress in modernizing QtMoko to build a newer version and fix compatibility issues.

BR,
Nikolaus



More information about the Gta04-owner mailing list