[Gta04-owner] QtMoko snapshot

H. Nikolaus Schaller hns at goldelico.com
Fri Dec 29 21:52:24 CET 2017


Hi Thierry,

> Am 29.12.2017 um 21:43 schrieb tgrauss <tgrauss at f-gp.eu>:
> 
> Hi,
> 
> Thank you so much, it is alive again :)
> Should I try to install the new bootloader again?

Yes, please try. It is just switching

>> DEV=/dev/sdb ./makesd gta04one -f1 -b GTA04-OneNAND/2017-05-13
and
>> DEV=/dev/sdb ./makesd gta04one -f1 -b GTA04-OneNAND/latest

This would help to find out if for some reason the "latest" package
is broken (I can't exclude that).

> What should I do to install a debian ready to install the test the new
> qtmoko?
> I don't want to try such experience again :/

What I plan is to set up my build-server in a way that it produces
a qtmoko image that you can install on an SD card with makesd.

This should then be fail-safe.

Generally you should use a single-partition SD card for such experiments
since it can't overwrite the boot loader then.

BR,
Nikolaus

> 
> BR
> 
> Thierry
> 
> On Fri, 29 Dec 2017 21:14:50 +0100
> "H. Nikolaus Schaller" <hns at goldelico.com> wrote:
> 
>> Hi,
>> 
>>> Am 29.12.2017 um 20:52 schrieb tgrauss <tgrauss at f-gp.eu>:
>>> 
>>> Hi,
>>> 
>>> On Fri, 29 Dec 2017 19:42:34 +0100
>>> Andreas Kemnade <andreas at kemnade.info> wrote:
>>> 
>>>> Hi,
>>>> 
>>>> On Fri, 29 Dec 2017 19:15:59 +0100
>>>> tgrauss <tgrauss at f-gp.eu> wrote:
>>>> 
>>>>> Hi,
>>>>> 
>>>>> I tried to install a Debian to test the qtmoko package.
>>>>> I have already installed the new U-boot successfully.
>>>>> Now, I used the makesd script to recreate a new filesystem on the
>>>>> sd card and unzipped the latest minimal debian root file
>>>>> system.    
>>>> 
>>>> = stretch or jessie?  
>>> it was stretch (latest-armhf-minimal.tbz)
>>> I have used makesd gta04
>>> I have then moved the content of the second partition to a temporary
>>> folder. I have uncompressed the latest-armhf-minimal.tbz in the sd
>>> card second partition then I have copied the lib/modules folder
>>> from the temporary folder into the /lib directory in the partition.
>>> I have then put the sd card in the phone and booted.
>>> 
>>>>> 
>>>>> I tried booting this and the screen flashed red 2 times
>>>>> immediately after inserting the battery, then a blinking cursor
>>>>> and nothing else.    
>>>> 
>>>> Can you confirm that the sd card has no boot.scr. u-boot.img, etc
>>>> on it? It looks like the bootloader was re-flashed again for some
>>>> reason. Just blinking cursor might be ok for a minimal image, you
>>>> should be able to login via ssh.  
>>> The sd card has a boot.scr,u-boot.img etc on the first partition.
>>> 
>>>>> Thinking about a problem with the debian system, I forced the
>>>>> phone to turn off by pressing the power button for a long time.
>>>>> 
>>>>> After this, impossible to turn on the phone any more.
>>>>> 
>>>> = No reaction on the serial console, the screen and the leds? No
>>>> difference with aux button pressed?
>>>> 
>>> No reaction anymore on the screen and button/leds. No reaction with
>>> both buttons pressed either :(  
>> 
>> That does not sound good. There should be at least some cryptical
>> characters.
>> 
>>> There is nothing on the serial line also using the USB cable :(
>>> I have also tried pserial using the JTAG cable like this : 
>>> ./pserial -p /dev/ttyUSB0 -f uart-monitor.bin
>>> and it is waiting for the ASIC id and nothing happen...  
>> 
>> Well, what could be a very rare situation is that the MLO in flash is
>> broken in a way that it is found before pserial is queried for but
>> the MLO does not load/find u-boot anywhere.
>> 
>> But then you should be able to force MMC boot by pressing the user
>> button.
>> 
>> If you have a spare SD card, please try
>> 
>> DEV=/dev/sdb ./makesd gta04one -f1 -b GTA04-OneNAND/2017-05-13
>> 
>> and try to boot with AUX button pressed (maybe after cleaning the µSD
>> card contacts). This would be the previous release of the boot loader
>> system.
>> 
>> BR,
>> Nikolaus
>> 
>> _______________________________________________
>> Gta04-owner mailing list
>> Gta04-owner at goldelico.com
>> http://lists.goldelico.com/mailman/listinfo.cgi/gta04-owner
> 
> _______________________________________________
> Gta04-owner mailing list
> Gta04-owner at goldelico.com
> http://lists.goldelico.com/mailman/listinfo.cgi/gta04-owner



More information about the Gta04-owner mailing list