[Gta04-owner] 4.3-rc6 available

Andreas Kemnade andreas at kemnade.info
Thu Oct 29 19:47:46 CET 2015


Hi,

On Thu, 29 Oct 2015 17:50:08 +0100
"H. Nikolaus Schaller" <hns at goldelico.com> wrote:


> > Somehow I managed to enable charging last evening. I have just to check
> > what was the cause. 
> > bci->transceiver was NULL
> > At least I know that the hackisch twl4030_charger_enable_usb_ext
> > was missing. It is used from  drivers/phy/phy-twl4030-usb.c 
> > There has to be a cleaner way to get to the bci pointer from there.
> > But why that did not break usb completely?
> 
> I have found a different fix. It is a problem when bci->transceiver is not
> yet probed but returns EPROBE_DEFER.
> 
Now I understand what I was doing. I compiled it statically into the kernel 
which solves the defer problem, but gives the error message with that hackish 
twl4030_charger_enable_usb_ext. So I fixed that.

> Then it works even without the hackish twl4030_charger_enable_usb_ext
> in drivers/phy/phy-twl4030-usb.c i.e. if I checkout the official drivers/phy/phy-twl4030-usb.c
> into our tree.
> 
Well, the hackish twl4030_charger_enable_usb_ext was for re-enabling  charging after disabling
vbus_out. I have to dig a bit in /dev/brain about it.

> So I think we can remove that hack completely.
>
Well, I am not completely sure about that.
 
Regards,
Andreas Kemnade
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 490 bytes
Desc: not available
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20151029/d885ea26/attachment-0001.asc>


More information about the Gta04-owner mailing list