[Gta04-owner] Replicant: no sound during calls

Lukas Maerdian luk at slyon.de
Mon Jan 5 11:20:54 CET 2015


Am 04.01.2015 um 23:35 schrieb L.B.:
> On 04/01/15 10:18, Lukas Maerdian wrote:
>> Am 03.01.2015 um 23:31 schrieb L.B.:
>>> Hi all,
>>>
>>> First of all I wish you a very happy new year!
>>> For a good start in 2015 I decided to try Replicant on my GTA04 and
>>> downloaded the auto-install script from Goldelico git repo (which looks
>>> recently updated):
>>>
>>> http://git.goldelico.com/?p=gta04-makesd.git;a=blob;f=makesd-replicant;h=630e92ffc2baf5e3d332cf11896317fc61e2fa1d;hb=HEAD
>>>
>>> It all went well and installed replicant on my 32GB SDcard. All booted
>>> very well too and within 5 min I could use the Wifi without problem and
>>> Bluetooth also seemed to work (I have to find another device to make
>>> sure but the slider does witch correctly).
>>> I could install a couple of packages to record and play sound, configure
>>> the ring tones and other niceties.
>>> Then I tested the calls: I can make phone calls and receive some, but I
>>> cannot hear anything nor can I speak to the other when the call starts.
>>> No sound at all during the call, on both side.
>>> I tried modifiying the sound preferences but it looks like the problem
>>> is deeper than that. Is this a known bug?
>>> By the way, congratulations for all the work on replicant! last time I
>>> tried it was a year ago and a lot has been done since then.
>> Hi!
>>
>> I recently implemented software-routing for audio in voice calls and the
>> changes are working and in the git repository. But the latests testing
>> image (which makesd makes use of) does not yet include those changes.
>>
>> So you would either need to compile Replicant yourself, according to
>> this documentation:
>>   http://projects.goldelico.com/p/gta04-replicant/page/Replicant-4/
>>
>> Or you would need to wait for the release of a new Goldelico Replicant
>> version, which I hope to be soon, but I want to fix one last bug (modem
>> suspend/resume) before doing a new testing release.
>>
>> Best,
>>   Lukas
>>
> I followed the instructions from the doc (I also had to use 'sudo
> update-alternatives --config javac' to use java-7-openjdk-amd64 because
> version 8 is not accepted for compilation) but I ran into some problems:
> 
> first, both the bootimage and tarball processes complain about not
> finding device/goldelico/gta04/recovery.fstab, plus a few other errors:
> *cut*
> Checking build tools versions...
> grep: device/goldelico/gta04/recovery.fstab: No such file or directory
> fatal: No annotated tags can describe
> '161f26dcfb2f9ff69e3ba5457d8074157f1ced33'.
> However, there were unannotated tags: try --tags.
> fatal: No annotated tags can describe
> '161f26dcfb2f9ff69e3ba5457d8074157f1ced33'.
> However, there were unannotated tags: try --tags.
> fatal: No annotated tags can describe
> '161f26dcfb2f9ff69e3ba5457d8074157f1ced33'.
> However, there were unannotated tags: try --tags.
> fatal: No annotated tags can describe
> '161f26dcfb2f9ff69e3ba5457d8074157f1ced33'.
> However, there were unannotated tags: try --tags.
> *cut*
> This did not prevent the process, though. Are these really problematic?

Hi.

I see those too, they are not problematic. It's just that git cannot
find certain tags.

> Then the tarball fails to be generated with the following error:
> *cut*
> host C++: libcts_audio_quality <= cts/suite/audio_quality/lib/src/Adb.cpp
> In file included from /usr/include/stdlib.h:25:0,
>                  from cts/suite/audio_quality/lib/src/Adb.cpp:16:
> /usr/include/features.h:323:26: fatal error: bits/predefs.h: No such
> file or directory
> compilation terminated.
> *cut*
> Where is that file?

Hmm, sounds like you're missing some of the build dependencies. Please
check the official Replicant documentation and see if you have all the
dependencies installed:
http://redmine.replicant.us/projects/replicant/wiki/BuildDependenciesInstallation

Best,
  Lukas

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 473 bytes
Desc: OpenPGP digital signature
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20150105/76e38ec6/attachment.asc>


More information about the Gta04-owner mailing list