[Gta04-owner] Replicant-4.2 for GTA04

Lukas Maerdian luk at slyon.de
Tue Mar 25 16:31:23 CET 2014


Hi Alexandre,

2014-03-19 6:57 GMT+01:00 Alexandre Roumiantsev <ran at mail.wplus.net>:
> Please, look at patches I published at http://lists.goldelico.com/pipermail/gta04-owner/2014-February/005345.html
> The lines:
> diff -ur gta04-replicant-device-replicant-4.2-ca249a4/init.gta04.rc /home/ran/my/device/goldelico/gta04/init.gta04.rc
> --- gta04-replicant-device-replicant-4.2-ca249a4/init.gta04.rc  2014-02-21 15:39:08.000000000 +0400
> +++ /home/ran/my/device/goldelico/gta04/init.gta04.rc   2014-02-25 09:51:31.813257000 +0400
> @@ -122,5 +120,6 @@
>  #      disabled
>  #      oneshot
>
> -service sdcard /system/bin/sdcard /data/media 1023 1023
> +service sdcard /system/bin/sdcard /data/media /mnt/sdcard 1023 1023
>         class late_start
>
> define "emulated SDCARD", which is useful in our case. ( It is possible other solutions, such as special partition and so )
> It not depend which partition scheme is used: goldelico one partition or replicant multipartitions with initrd.
> Emulated sdcard work well in both case. You can see how it work with this build:
> https://drive.google.com/file/d/0B-rRgKAzYyoBOHZTT1k2UmtMSHc/edit?usp=sharing
>
>> No, it just worked.  This is with the single partition
>> gta04-rootfs.tar.gz, which I unpacked to my /dev/mmcblk0p1 using tar
>> jxvf (just as you'd expect).
>>
>> My /dev/mmcblk0p1 is formatted as ext3 - could that be relevant?
>>
>> Also I have an /dev/mmcblk0p5 that is formatted as vfat and that
>> contains music and pictures from other distros, and which the Replicant
>> media player automatically found.
>
> It is a result auto vold work. For me it is not good and I tried to exclude vold,
> but did not find a way to do it correctly. However emulated sdcard cover this problem and
> I did not spend a time to it.

With this change the Settings UI (Settings -> Storage) detects the
current partition as "Internal Storage".
Then I open F-Droid and try to install any applicantion. It downloads,
but then I get this error message: "There was a problem parsing the
package".

Did you ever see such an error? Or do you know what it means? Did you
manipulate the storage_list.xml in any way?

BR,
  Lukas


More information about the Gta04-owner mailing list