[Gta04-owner] uboot dependency (was: Goldelico Replicant 4.2 with Wifi)

Lukas Maerdian luk at slyon.de
Mon Mar 24 18:26:45 CET 2014


2014-03-19 21:45 GMT+01:00  <mx4812 at arcor.de>:
>
>> >  update my uboot, if that's needed?
>>
>> Yes, looks like you have an old U-Boot.
>
> Maybe the replicant script could check for the uboot
> version dependency, and stop booting with a howto/link
> telling the user to update the bootloader.

I've now added a fallback case to the replicant script, in which the
(more) universal twl4030_madc_battery driver gets loaded, if no
matching mux= parameter is found, in addition to printing a warning
about the missing parameter:
https://github.com/OpenPhoenux/gta04-replicant-device/commit/c9b527f2be064a48367022e85bbfb06fbceb9007

I think the decision to stop booting should not be done from a
userland script, but rather from the kernel. This is already prepared,
but not implemented here:
https://github.com/OpenPhoenux/gta04-kernel/blob/3.12-replicant4/arch/arm/mach-omap2/board-omap3gta04.c#L1779

This should provide users, even with old uboot versions, to use the
basic battery driver.

BR,
  Lukas


More information about the Gta04-owner mailing list