[Gta04-owner] Kernel 3.16-rc2

Benjamin Deering ben_deering at swissmail.org
Fri Jun 27 00:48:54 CEST 2014


On 06/23/2014 09:59 AM, Dr. H. Nikolaus Schaller wrote:
> Am 23.06.2014 um 15:40 schrieb Neil Jerram:
>
>> On 2014-06-23 13:13, Dr. H. Nikolaus Schaller wrote:
>>
>>> Just install the latest u-boot to NAND flash (no need to reflash the
>>> kernel/rootfs) from
>>> 	http://download.goldelico.com/gta04/20140610-GTA04-beta-3.15.0-wheezy-7.5/
>>> It will automatically detect which board you have, load the correct
>>> device tree file
>>> and therefore you can copy all of them to the SD card. And there is no
>>> need to append
>>> it to the zImage any more.
>>> After flashing the new u-boot, it is sufficient to have some ext2/3/4
>>> partition which
>>> provides /boot/uImage, /boot/*.dtb and /boot/bootargs.scr
I spent some more time with this tonight.  I don't see an sd image in

http://download.goldelico.com/gta04/20140610-GTA04-beta-3.15.0-wheezy-7.5/


but I grabbed the u-boot files and copied them to /boot in an older 
hardware validation sd image. I booted this image and flashed the new 
u-boot. After this, I couldn't boot from any sd cards, it would always 
fall back to NAND. After putting back the old u-boot (Jun 2013) my cards 
all work.

I must be doing something wrong, but I have no idea what.

My cards are ext3 formatted.  None of them have the old MLO stuff 
installed.  My boot folder contains the dtb files, uImage, bootargs.scr, 
logo.bmp.

Neil, were you successful in booting 3.16-c2?

Thanks,

Ben



More information about the Gta04-owner mailing list