[Gta04-owner] u-boot problems

Benjamin Deering ben_deering at swissmail.org
Thu Jun 26 03:56:33 CEST 2014


Hello all,

I stopped goofing around with gyros and tried to install the latest 
kernel.  In order to take
advantage of devicetree, I needed to upgrade u-boot. so I got u-boot.bin 
from 
http://download.goldelico.com/gta04/20140610-GTA04-beta-3.15.0-wheezy-7.5/

and tried to flash it with

flash_eraseall /dev/mtd1;
nandwrite -p u-boot.bin /dev/mtd1

This booted to a white screen, so I made an sd card of the hw-validation 
image and booted from that, got a red screen and u-boot was restored.

This time I got u-boot.flash from the same site and tried to flash 
that.  My gta04 is now just showing a black screen.  I do see 'Das 
U-Boot' if I boot while connected to USB, so I dont think I broke any 
hardware.

Am I correct that I need to load u-boot over serial now?  I don't have a 
serial cable and shipping would be prohibitively expensive to order one 
from GDC.  Is it correct that I need these: 
http://www.digikey.com/product-search/en?mpart=0006660013&vendor=900 
<http://www.digikey.com/product-search/en?mpart=0006660013&vendor=900> 
and this: 
http://www.digikey.com/product-search/en?vendor=0&keywords=51021-0800 
<http://www.digikey.com/product-search/en?vendor=0&keywords=51021-0800> 
(along with some more wire and a db9 connector) to make one?

Thanks,

Ben


More information about the Gta04-owner mailing list