[Gta04-owner] Can't install/boot QtMoko from microSD

habs at SDF.ORG habs at SDF.ORG
Tue Jun 25 21:57:40 CEST 2013

> Hi,
> your setup looks to me good. Can you try to SSH to the device and maybe
> launch
> qtmoko manually so that it prints something useful:
> 	ifconfig usb0
> 	ssh root at
> 	/etc/init.d/qtmoko-gta04 stop
> 	. /opt/qtmoko/qpe.env
> 	qpe
> If it goes well please send the output. If you can't SSH, then it probably
> didnt mount rootfs well - we can try some debugging then.

I guess it didn't mount rootfs well, because I can't seem to connect to it
via USB while the QtMoko uSD logo is showing.

When I type "ifconfig" with the phone attached and the uSD logo showing, I
still only see "eth0" and "lo". Here is the output of the first command
you gave me:

SIOCSIFADDR: No such device
usb0: ERROR while getting interface flags: No such device

I have tried reformatting the uSD card multiple times only to get the same
result. Replicant, on the other hand, worked both of the times I tried to
burn it onto the same uSD, so I doubt it is a problem with the actual
card. Where can we go from here to debug this?

More information about the Gta04-owner mailing list