[Gta04-owner] Can't install/boot QtMoko from microSD

Radek Polak psonek2 at seznam.cz
Wed Jun 26 11:10:08 CEST 2013

On Tuesday, June 25, 2013 09:57:40 PM habs at sdf.org wrote:

> > Hi,
> > your setup looks to me good. Can you try to SSH to the device and maybe
> > launch
> > 
> > qtmoko manually so that it prints something useful:
> > 	ifconfig usb0
> > 	ssh root at
> > 	/etc/init.d/qtmoko-gta04 stop
> > 	. /opt/qtmoko/qpe.env
> > 	qpe
> > 
> > If it goes well please send the output. If you can't SSH, then it
> > probably didnt mount rootfs well - we can try some debugging then.
> I guess it didn't mount rootfs well, because I can't seem to connect to it
> via USB while the QtMoko uSD logo is showing.
> When I type "ifconfig" with the phone attached and the uSD logo showing, I
> still only see "eth0" and "lo". Here is the output of the first command
> you gave me:
> SIOCSIFADDR: No such device
> usb0: ERROR while getting interface flags: No such device
> I have tried reformatting the uSD card multiple times only to get the same
> result. Replicant, on the other hand, worked both of the times I tried to
> burn it onto the same uSD, so I doubt it is a problem with the actual
> card. Where can we go from here to debug this?

Can you try first this:

during boot press AUX so that the uboot menu is shown. Make sure to select SD1 
(boot from the first FAT) if this helps.

Otherwise you can try to modify bootargs.scr on the FAT. Copy it to 
bootargs.scr.in and edit in nano. Remove the first line and substitute 
"console=ttyO2,115200n8" with "console=tty0". Then you need this command (from 
uboot-mkimage package):

mkimage -A arm -O linux -a 0 -e 0 -T script -C none -n "GTA04 Boot Script" -d 
bootargs.scr.in bootargs.scr

After boot from SD1 you should see kernel messages on the display. Same can be 
achieved by using serial port - so that you dont have to fiddle with 

I hope i have the command right - havent tested it...


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20130626/00a021a3/attachment-0001.html>

More information about the Gta04-owner mailing list