[Gta04-owner] qtmoko-armhf buildhost: where to get wheezy-armhf.img?

Radek Polak psonek2 at seznam.cz
Sun Jun 9 11:48:43 CEST 2013

On Sunday, June 09, 2013 10:57:00 AM Adrien Dorsaz wrote:

> Hello!
> I've made several tests, but I'm unable to use qemu image for the GTA04.
> I've tried my own wheezy-armhf image created with debootstrap [0] and
> I've tried the v55 qtmoko tarball, but I've always the same issue on
> boot :

Are you really supplying qemu image? What does:

	file wheezy-armhf.img

say? It should be something like this:

radek at rp-core:~/qte/qtmoko-buildhost-apps$ file wheezy-armhf.img 
wheezy-armhf.img: QEMU QCOW Image (v2), 34359738368 bytes

> Begin: Waiting for root file system ... done.
> Gave up waiting for root device.  Common problems:
>  - Boot args (cat /proc/cmdline)
>    - Check rootdelay= (did the system wait long enough?)
>    - Check root= (did the system wait for the right device?)
>  - Missing modules (cat /proc/modules; ls /dev)
> ALERT!  /dev/mmcblk0p1 does not exist.  Dropping to a shell!
> Indeed, in the startup.sh script, there's an option which precise the
> rootfs is on /dev/mmcblk0p1, but there's no uSD card into the image.

vexpress kernel has no support for ATA/SATA - instead of this it uses SD card 

> Could you share with us how you create your wheezy armhf image ? Or have
> I to modify the startup.sh ?

I have created it with qemu utility for creating virtual machine disks - 
something like qcow... Dunno exactly the commands, but it it's very easy to 
google them up.



More information about the Gta04-owner mailing list