[Gta04-owner] qtmoko-armhf buildhost: where to get wheezy-armhf.img?

Dr. H. Nikolaus Schaller hns at goldelico.com
Sun Jun 9 11:31:07 CEST 2013

Hi Adrien,

Am 09.06.2013 um 10:57 schrieb Adrien Dorsaz:

> Le mardi 21 mai 2013 à 08:53 +0200, Radek Polak a écrit :
>> On Monday, May 20, 2013 11:45:48 PM arne anka wrote:
>> you can probably most easily do it on GTA04. Just create ext3 or ext4
>> loopback image, mount it and either use cdebootstrap or you can even
>> use qtmoko release tarball for base system. Before unmounting it would
>> be good idea to install qemu friendly kernel [1] so that modules are
>> loaded.
> Hello!
> I've made several tests, but I'm unable to use qemu image for the GTA04.
> I've tried my own wheezy-armhf image created with debootstrap [0] and
> I've tried the v55 qtmoko tarball, but I've always the same issue on
> boot :
> Begin: Waiting for root file system ... done.
> Gave up waiting for root device.  Common problems:
> - Boot args (cat /proc/cmdline)
>   - Check rootdelay= (did the system wait long enough?)
>   - Check root= (did the system wait for the right device?)
> - Missing modules (cat /proc/modules; ls /dev)
> ALERT!  /dev/mmcblk0p1 does not exist.  Dropping to a shell!
> Indeed, in the startup.sh script, there's an option which precise the
> rootfs is on /dev/mmcblk0p1, but there's no uSD card into the image.
> Could you share with us how you create your wheezy armhf image ? Or have
> I to modify the startup.sh ?

You can try this rootfs:


It was simply created using debootstrap on a GTA04 by using this script
and then extracting the new rootfs:


Two things are critical:
1. the debootstrapped rootfs must be configured a little
2. the kernel modules must be part of the new rootfs

What I have not tried is to use this rootfs in qemu but it works on a GTA04.

Hope this helps,

More information about the Gta04-owner mailing list