[Gta04-owner] debian: sshd dies after a few minutes

arne anka openmoko at ginguppin.de
Fri Jan 4 18:47:37 CET 2013

after some more probing it turns out, that starting X kills sshd -- X  
doesn't really start (screen turns yellow and that's it), but it suffices  
to lock me out.
changed default runlevel to something w/o X and can stay connected via ssh  
unlimited -- the moment i fire up X, i can count down to freeze.

anyone an idea what might cause this?

> i upgraded the squeezy image to sid and experience consistently that the  
> sshd (ie the daemon on the GTA04!) freezes after a few minutes.
> usually it happens during an active connection, but just now i've seen  
> it after a reboot w/o connection -- rebooted, left the room for a while  
> and when i came back, i couldn't even log in.
> tried several approaches, but so far nothing fixes this -- since in the  
> process i managed to kill X/LXDE, i am unable to do anything on the  
> GTA04 itself and have to reboot the device forcibly every time.
> i still can ping it, so the network itself seems to be up ...
> has anyone seen this and knows, what to do about it? with the GTA02 i've  
> seen this kind of behaviour with the dropbear server -- switching to  
> debian's fullfledged sshd solved it back then, but now opensssh-server  
> is installed already.

More information about the Gta04-owner mailing list