[Gta04-owner] bq27000-battery: battery is not calibrated! ignoring capacity values

EdorFaus edorfaus at xepher.net
Sun Feb 3 22:47:03 CET 2013


On 02/03/2013 05:18 PM, Bob Ham wrote:
> I'm wondering if anybody here can provide some authoritative information

I'm not an authority on the subject, but I figured I could provide some 
details on my (limited) understanding of the problem, just so we're all 
on the same page.

> What precisely is it that needs calibration?
> Why does reporting the charge depend on this calibration?

The OpenMoko battery contains a bit more circuitry than most batteries, 
including a bq27000 chip. This chip measures and keeps track of several 
things about the battery, including the current going into or out of the 
battery, and this lets it know the charge level of the battery. The 
GTA0x then communicates with this chip via the third contact to display 
information about the battery, such as max and current charge level, and 
the mA currents we see on the home screen.

Keeping this chip inside the battery instead of in the GTA0x is because 
it allows you to have more than one battery, and/or use the battery in 
more than one device, while still maintaining accurate and up-to-date 

That bq27000 chip is what appears to needs calibration, presumably to 
know the characteristics of the actual battery it is in, I'm guessing it 
in particular it needs to know the max and min charge levels that the 
battery will hold, to be able to calculate things like how full the 
battery is or how long it is until it's empty.

While it apparently knows the values the battery was designed for, those 
values will change as the battery wears down (which, for LiIon 
batteries, includes simple time passed), and it needs to know the 
actual, measured, values to have any accuracy.

> How is the calibration performed, and by what?  Is there a problem with
> the GTA04's hardware, or with the kernel, or is this expected behaviour?

I assume the calibration is performed by the chip itself, when the 
device/user follows some kind of procedure to calibrate it, meaning that 
this is (kind of) expected behavior.

The problem is that, since we haven't seen the datasheet or any other 
relevant information, we don't actually know what that calibration 
procedure is supposed to be.

I guessed that the discharge-recharge cycle would do it based on some 
information I read about some completely different battery (for a Mac 
IIRC) that apparently had something similar in it, but it is a pure 
guess that it would use the same (or an equivalent) chip, or that the 
procedure would be the same.

On 02/03/2013 05:18 PM, Bob Ham wrote:
> Unfortunately, charging and discharging my battery has not helped.  I
> have had it charge/discharge continuously for weeks and I still get the
> errors.  This includes complete discharges followed by a spell in the
> GTA01 to charge the battery to a level where it can power the GTA04 for
> a full boot.  I still get the same kernel error messages.

Yeah, that's something I probably didn't make completely clear in my 
previous mail, that I disabled powermanagement and stuff so that it 
would discharge completely (power off the device due to lack of power, 
not due to software noticing it had little left), and then left it 
overnight or so after that. I see you did the same anyway though.

I used the GTA04 to recharge it though, and made sure to recharge it 
completely, and IIRC left it charging a while longer just to make sure. 
(Or was that in the initial charge before the deep discharge... I don't 
really remember.)

I only did this procedure once, not multiple times. I was already 
worried before I did it, because I know that LiIon batteries don't like 
being completely discharged. (For longevity, they actually prefer being 
around 50% charged, and to be fairly cold.)

As I mentioned, it didn't immediately start to work for me either, but 
after a few minutes, it started providing information.

So, for all I know, it might have been a coincidence that it started 
working for me after I did that.

Like you, I sure would like to see some kind of official information 
about this, preferably including the documentation on calibration.

I kind of think it would be better if the factory calibrated the 
batteries before they shipped them, but I guess that's impractical for 
several reasons. Not the least of which would be that it might be a 
while before they're sold, which can change their characteristics.

By the way, as I mentioned in that mail, my (brand-new, for me at least) 
battery already had a quite a bit lower charge_full than 
charge_full_design, so using charge_full_design is likely to be 
inaccurate for many.

Another point to consider is that, if this is changed so that it's not 
really visible to the user when the battery isn't calibrated, they're 
unlikely to look for information about it - and thus unlikely to get 
their batteries calibrated, which I assume would leave them with much 
less accurate battery information. So we might want to show it somehow - 
a different color on the battery indicator? An exclamation mark next to 
it? A message on the home screen? I don't know what would be best, or if 
such information would even be desired by anyone other than me, but I 
tend to favor providing such information whenever possible, because I 
know I would prefer getting it.

Frode Austvik

More information about the Gta04-owner mailing list