[Gta04-owner] Modem reenummerating (was: Re: Crowdfunding an Ubuntu smartphone)

Dr. H. Nikolaus Schaller hns at goldelico.com
Wed Aug 28 14:54:31 CEST 2013


Hi Radek,

Am 28.08.2013 um 12:07 schrieb Radek Polak:

> On Tuesday, August 27, 2013 03:06:44 PM Dr. H. Nikolaus Schaller wrote:
>  
> > 
> > What makes me worried most is not the problem, but that there is no Issue
> > report here:
> > 
> > 	http://projects.goldelico.com/p/gta04-kernel/issues/
> > 
> > For further analysis of this issue we need:
> > 
> > 1. collected reports from as many users how they see and experience the bug
> > 2. a reference setup how to enforce the bug
> > 3. always describe which kernel version is used (it may depend on that!)
>  
> http://projects.goldelico.com/p/gta04-kernel/issues/478/
>  

Thanks for posting the precise information to a location where we can find it!

I have now done a simple setup myself:

0. GTA04A4 with 800 MHz CPU
1. Linux-3.11-rc7 kernel with Debian wheezy armhf rootfs
2. ./wwan-status (from the hw-validation rootfs) - it enables the modem and some unsolicited status messages
3. ./femtocom /dev/ttyHS_Application
4. AT_OPSYS=2,3
5. call the device's phone number & hangup after two or 3 ring tones (because the mailbox jumps in after 4 or 5)

I have tried 12 times with these results:

* always did get 2 or 3 "RING" messages
* some _OSIGQ: 6,0 or _OSIGQ: 2,0 (which is quite weak signal)
* no reenumeration within 12 tries

Did I not try long or often enough (since it is more sporadic) or is something
fundamentally missing in my scenario (e.g. kernel going to suspend when
incoming call does a wakeup)?

BR,
Nikolaus


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20130828/cb63791b/attachment.html>


More information about the Gta04-owner mailing list