[Gta04-owner] 3G internet connection

Sven openmoko at maricon.de
Mon Apr 22 22:42:51 CEST 2013


Hello Radek,

I now tried the following:

- Power on the phone. After entering PIN I get a black "G" displayed.
- ssh into the phone and execute:  echo "AT_OPSYS=1" > /dev/ttyHS_Modem
- Within Qtmoko choose "Settings" / "Internet" / "Start".

Result: I get "Pending" and then nothing anymore. No reaction to "Stop" 
or anything else. Have to powercycle the phone.

After powercycle I tried another workflow:

- Entering PIN, then get black "G" displayed.
- Within Qtmoko choose "Settings" / "Internet" / "Start". After that I 
get a white "G" displayed.
- ssh into the phone and execute:  echo "AT_OPSYS=1" > /dev/ttyHS_Modem
- Browse some page from the net.

Result: Works, but as slow as it already was before.

What do you recommend what I should try, now?

Best regards
    Sven



On 22.04.2013 10:25, Radek Polak wrote:
>
> On Sunday, April 21, 2013 01:09:19 AM Sven wrote:
>
> > I know it had already been discussed for several times, but now also I
>
> > want to have the problem solved that I get only 2G connections...
>
> Some old QtMoko versions disabled 3G. But now the line is commented out:
>
> //chat("AT_OPSYS=0,2"); // disable UMTS, use only GSM
>
> so it should use 3G. Maybe you can try minicom and explictely tell 
> modem to use 3G - you can use /dev/ttyHS_Control for it. AT command 
> for it is nicely described here:
>
> http://wiki.debian.org/Modem/3G/Vodafone
>
> (search for "AT commands")
>
> Regards
>
>
> Radek
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20130422/c72bd2e1/attachment.html>


More information about the Gta04-owner mailing list