[Gta04-owner] charging battery

Dr. H. Nikolaus Schaller hns at goldelico.com
Mon Apr 22 09:51:19 CEST 2013


Am 22.04.2013 um 09:32 schrieb Liz:

> On Mon, 22 Apr 2013 02:46:07 +0200
> Boudewijn <wankelwankel at yahoo.com> wrote:
> 
>> On Sunday 21 April 2013 01:58:14 Liz wrote:
>>> my battery charging is erratic
>>> as if there is rarely an electrical connection on the power circuit
>>> although the USB connector is pushed fully in and there is power
>>> applied I've tried three different devices to power the phone and
>>> charge the battery with only intermittent success
>> 
>> Which OS are you running, and what are the symptoms? What do you mean
>> by 'devices'?
>> 
>> I think Alexander (Lehner) (sorry if it was someone else) wrote
>> something about tests with different USB cables, concluding that the
>> GTA04 was more specific about which power it liked than the GTA02. I
>> can't find the message; the closest are a message from Wed Nov  9
>> 18:35:49 2011 and one from Mon Mar 19 14:08:55 2012. The message I
>> had in mind had to do with the length of the USB cable as well: even
>> short ones are no guarantee for a good charge.
>> 
>> Charging as such should not be a problem, though. 
>> 
>> Another thing is keeping charge: depending on the OS, charging stops
>> when 100% charge is reached. That is OK, but it runs on battery after
>> that, and not always starts charging before the battery is almost
>> empty. I am not sure what the status of this situation is in each OS;
>> I thought that for qtmoko there's a threshold of 3.x V for charging
>> to kick in again.
>> 
>> Best regards,
>> 
>> Boudewijn
> 
> I've got qtmoko55 running
> the symptoms - the battery doesn't charge, there is no sign of battery
> charge on the screen, and the phone goes flat
> I have tried charging with 
> 	the original charger
> 	another wall charger which provides miniUSB connector and 5V DC
> 	a USB cable in the car which should provide 5V DC to miniUSB
> 	a USB cable attached to the USB hub in my monitor (about 15cm
> 	of cable)
> I can charge the battery in my ancient Nokia phone, but it's always flat
> I suspect that the battery may be past its use by date

Please run

echo "USB Charger"
echo "============"
echo online: $(cat /sys/devices/platform/omap_i2c.1/i2c-1/1-004b/twl4030_bci/power_supply/twl4030_usb/online 2>/dev/null)
echo type: $(cat /sys/devices/platform/omap_i2c.1/i2c-1/1-004b/twl4030_bci/power_supply/twl4030_usb/type)
echo status: $(cat /sys/devices/platform/omap_i2c.1/i2c-1/1-004b/twl4030_bci/power_supply/twl4030_usb/status 2>/dev/null)
echo volt: $(cat /sys/devices/platform/omap_i2c.1/i2c-1/1-004b/twl4030_bci/power_supply/twl4030_usb/voltage_now 2>/dev/null)uV
echo current: $(cat /sys/devices/platform/omap_i2c.1/i2c-1/1-004b/twl4030_bci/power_supply/twl4030_usb/current_now 2>/dev/null)uA
echo ID: $(cat /sys/devices/platform/omap_i2c.1/i2c-1/1-0048/twl4030_usb/id 2>/dev/null)

echo
echo "AC Charger"
echo "============"
echo online: $(cat /sys/devices/platform/omap_i2c.1/i2c-1/1-004b/twl4030_bci/power_supply/twl4030_ac/online 2>/dev/null)
echo type: $(cat /sys/devices/platform/omap_i2c.1/i2c-1/1-004b/twl4030_bci/power_supply/twl4030_ac/type 2>/dev/null)
echo status: $(cat /sys/devices/platform/omap_i2c.1/i2c-1/1-004b/twl4030_bci/power_supply/twl4030_ac/status 2>/dev/null)
echo volt: $(cat /sys/devices/platform/omap_i2c.1/i2c-1/1-004b/twl4030_bci/power_supply/twl4030_ac/voltage_now 2>/dev/null)uV
echo current: $(cat /sys/devices/platform/omap_i2c.1/i2c-1/1-004b/twl4030_bci/power_supply/twl4030_ac/current_now 2>/dev/null)uA

# see http://www.mjmwired.net/kernel/Documentation/hwmon/twl4030-madc-hwmon
echo
echo "Main Battery"
echo "============"
VOLT=$(cat /sys/devices/platform/twl4030_madc_hwmon/in12_input)
echo volt: ${VOLT}mV ca. $(expr \( "$VOLT" - 3300 \) \* 100 / 950)%
echo current: $(cat /sys/devices/platform/twl4030_madc_hwmon/curr10_input)mA
echo temp: $(cat /sys/devices/platform/twl4030_madc_hwmon/temp1_input)°C
echo type: $(cat /sys/devices/platform/twl4030_madc_hwmon/in0_input)mV
echo ADC7: $(cat /sys/devices/platform/twl4030_madc_hwmon/in7_input)mV	# MICSENSE
echo VBUS: $(cat /sys/devices/platform/twl4030_madc_hwmon/in8_input)mV
echo VCHG: $(cat /sys/devices/platform/twl4030_madc_hwmon/in11_input)mV

echo
echo "Backup battery"
echo "=============="
echo volt: $(cat /sys/devices/platform/twl4030_madc_hwmon/in9_input)mV

echo
echo "BQ27000 (if HDQ works)"
echo "======================"
echo present: $(cat /sys/devices/w1_bus_master1/01-000000000000/bq27000-battery/power_supply/bq27000-battery/present 2>/dev/null)
echo type: $(cat /sys/devices/w1_bus_master1/01-000000000000/bq27000-battery/power_supply/bq27000-battery/type 2>/dev/null)
echo technology: $(cat /sys/devices/w1_bus_master1/01-000000000000/bq27000-battery/power_supply/bq27000-battery/technology 2>/dev/null)
echo capacity: $(cat /sys/devices/w1_bus_master1/01-000000000000/bq27000-battery/power_supply/bq27000-battery/capacity 2>/dev/null)%
echo status: $(cat /sys/devices/w1_bus_master1/01-000000000000/bq27000-battery/power_supply/bq27000-battery/status 2>/dev/null)
echo level: $(cat /sys/devices/w1_bus_master1/01-000000000000/bq27000-battery/power_supply/bq27000-battery/capacity_level 2>/dev/null)
echo volt: $(cat /sys/devices/w1_bus_master1/01-000000000000/bq27000-battery/power_supply/bq27000-battery/voltage_now 2>/dev/null)uV
echo current: $(cat /sys/devices/w1_bus_master1/01-000000000000/bq27000-battery/power_supply/bq27000-battery/current_now 2>/dev/null)uA
echo temp: $(cat /sys/devices/w1_bus_master1/01-000000000000/bq27000-battery/power_supply/bq27000-battery/temp 2>/dev/null)/10°C
echo charge: $(cat /sys/devices/w1_bus_master1/01-000000000000/bq27000-battery/power_supply/bq27000-battery/charge_now 2>/dev/null)uAh
echo full: $(cat /sys/devices/w1_bus_master1/01-000000000000/bq27000-battery/power_supply/bq27000-battery/charge_full 2>/dev/null)uAh
echo design: $(cat /sys/devices/w1_bus_master1/01-000000000000/bq27000-battery/power_supply/bq27000-battery/charge_full_design 2>/dev/null)uAh
echo energy: "$(cat /sys/devices/w1_bus_master1/01-000000000000/bq27000-battery/power_supply/bq27000-battery/energy 2>/dev/null)J?"
echo power: "$(cat /sys/devices/w1_bus_master1/01-000000000000/bq27000-battery/power_supply/bq27000-battery/power 2>/dev/null)W?"
echo cycles: $(cat /sys/devices/w1_bus_master1/01-000000000000/bq27000-battery/power_supply/bq27000-battery/cycle_count 2>/dev/null)
echo health: $(cat /sys/devices/w1_bus_master1/01-000000000000/bq27000-battery/power_supply/bq27000-battery/health 2>/dev/null)
echo discharge: $(cat /sys/devices/w1_bus_master1/01-000000000000/bq27000-battery/power_supply/bq27000-battery/time_to_empty_avg 2>/dev/null)s to empty
echo remaining: $(cat /sys/devices/w1_bus_master1/01-000000000000/bq27000-battery/power_supply/bq27000-battery/time_to_empty_now 2>/dev/null)s to "?"
echo charging: $(cat /sys/devices/w1_bus_master1/01-000000000000/bq27000-battery/power_supply/bq27000-battery/time_to_full_now 2>/dev/null)s to full

This should reveal useful information.

> 
> I am now playing with the battery from another phone to see if it is a
> failed battery more than a failed charging system
> _______________________________________________
> Gta04-owner mailing list
> Gta04-owner at goldelico.com
> http://lists.goldelico.com/mailman/listinfo/gta04-owner



More information about the Gta04-owner mailing list