[Gta04-owner] AUX Button

Lukas Märdian luk at slyon.de
Sat Apr 6 23:31:38 CEST 2013


Am 06.04.2013 20:41, schrieb Gerhard Rieger:
> On 2013-04-06 19:30, Dr. H. Nikolaus Schaller wrote:
>>
>> Am 06.04.2013 um 19:07 schrieb Gerhard Rieger:
>>
>>> Hi,
>>>
>>> I recently migrated to gta04. The AUX Button had not worked on gta02
>>> since some months (pressing it had no effect), and the same is still
>>> true with gta04. I suspect that - once pressed - the button does not
>>> return to its idle position. LEDs are working fine.
>>>
>>> How can I inquire the button state from HW validation or QtMoko?
>>
>> 2.6-kernel hwvalidation:
>>
>> 	http://projects.goldelico.com/p/gta04-kernel/page/Devices-Overview/#wikititle_8
> 
> My Debian Wheezy in NAND of a group tour device Dec.2012 does not have
> /sys/devices/virtual/gpio/gpio7/ (many others with different numbers though)
> 
>> 3.7 kernel: 
>>
>> 	evtest /dev/input/aux 
> 
> yes that works
> 
>>> What mechanism should bring the button back after pressing?
>>
>> The button part sitting on the PCB has a built-in spring with some small force.
>>
>> If the button is stuck this means that the plastic case has more friction than
>> the button's spring force.
>>
>> Please check if it works if you remove the display cover.
>>
>> If yes, you can try to scratch a little off the plastic parts of the transparent
>> AUX button part and/or the black plastics. Until it can be moved.
>>
>> Hope this helps.
> 
> Ah yes, forcing the guitar pick into the seam near the button releases
> it - thanks for your help!!
> 

Hi, I had the same problem quite some time ago.

Here is how I fixed it:
  http://lists.goldelico.com/pipermail/gta04-owner/2011-October/000516.html

Cheers,
  Lukas


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 490 bytes
Desc: OpenPGP digital signature
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20130406/625cf3d2/attachment.bin>


More information about the Gta04-owner mailing list