[Gta04-owner] Newbie alert: GTA04 starting issues

Sam Muirhead sam at yearofopensource.net
Mon Oct 22 14:05:40 CEST 2012


I'm a new user of the Open Phoenux, and I'm struggling to get things 
working, and I've got a few questions - the first one is should I be 
writing this here, or in the Community Nachrichtensammlung, or on a forum?

I received my GTA04 last week and wanted to install QtMoko. Initially 
the device turned on and booted LXDE quite happily, but since trying to 
install QtMoko I haven't been able to charge the battery or turn the 
device on. I read in a previous thread that if it doesn't boot, then it 
doesn't charge, which is what I assume is happening.
Bear in mind that I'm not particularly experienced with this kind of 
thing, so don't assume I've done the basics right, there are all sorts 
of areas where I could have gone wrong so I'll just go through what I tried:

I formatted a 16GB microSD card (255 heads, 63 sectors, 1936 cylinders) 
with 4 partitions:
    Device Boot      Start         End              Blocks Id  System
/dev/sdb1   *        2048      112453          55203         c  W95 
FAT32 (LBA)
/dev/sdb2          112454     2216968       1052257+  83  Linux
/dev/sdb3         2217984    10409983     4096000    b  W95 FAT32
/dev/sdb4        10409984    31115263    10352640   82  Linux swap / Solaris

I downloaded qtmoko-fat-v48.tar.gz 
<http://sourceforge.net/projects/qtmoko/files/GTA04/qtmoko-fat-v48.tar.gz/download> 
from sourceforge, and copied the MLO to partition 1, then the rest of 
the folder.
/media/5011-404B/gta04-init
/media/5011-404B/boot.scr
/media/5011-404B/bootargs.scr
/media/5011-404B/menu.rgb16z
/media/5011-404B/MLO
/media/5011-404B/splash.rgb16z
/media/5011-404B/u-boot.bin
/media/5011-404B/uImage
/media/5011-404B/user.scr
/media/5011-404B/x-load.flash

I extracted qtmoko-debian-gta04-v48.tar.gz 
<http://sourceforge.net/projects/qtmoko/files/GTA04/qtmoko-debian-gta04-v48.tar.gz/download> 
to the 2nd (Linux) partition:
/media/94a3c4b5-d522-4d48-abda-4f591bc068b2/bin
/media/94a3c4b5-d522-4d48-abda-4f591bc068b2/boot
/media/94a3c4b5-d522-4d48-abda-4f591bc068b2/dev
/media/94a3c4b5-d522-4d48-abda-4f591bc068b2/distros
/media/94a3c4b5-d522-4d48-abda-4f591bc068b2/etc
/media/94a3c4b5-d522-4d48-abda-4f591bc068b2/home
/media/94a3c4b5-d522-4d48-abda-4f591bc068b2/lib
/media/94a3c4b5-d522-4d48-abda-4f591bc068b2/lost+found
/media/94a3c4b5-d522-4d48-abda-4f591bc068b2/media
/media/94a3c4b5-d522-4d48-abda-4f591bc068b2/mnt
/media/94a3c4b5-d522-4d48-abda-4f591bc068b2/opt
/media/94a3c4b5-d522-4d48-abda-4f591bc068b2/proc
/media/94a3c4b5-d522-4d48-abda-4f591bc068b2/root
/media/94a3c4b5-d522-4d48-abda-4f591bc068b2/sbin
/media/94a3c4b5-d522-4d48-abda-4f591bc068b2/selinux
/media/94a3c4b5-d522-4d48-abda-4f591bc068b2/srv
/media/94a3c4b5-d522-4d48-abda-4f591bc068b2/sys
/media/94a3c4b5-d522-4d48-abda-4f591bc068b2/tmp
/media/94a3c4b5-d522-4d48-abda-4f591bc068b2/usr
/media/94a3c4b5-d522-4d48-abda-4f591bc068b2/var

I then inserted the SD card and tried to boot the GTA04. (not plugged 
into USB)
The gta04 init bootloader screen appeared, and I tried to select the SD 
card, but nothing happened. no response, no sound, no visible change.
I waited for one minute or so, then tried selecting NAND, just to see if 
it would do anything - still no change.
I removed the battery, removed the SD card, replaced the battery and 
tried to just boot to lxde again.
It didn't boot, there was no light from the power button, no other signs 
of life.

-It was around this point that I read something saying the battery 
should be fully charged when installing an OS - I don't know how much 
charge was on the battery when I started, but it took me a long time 
organising the SD card so it may have been low by the time I tried to 
boot it.

Previously when plugged in via USB I at least had a notification that a 
wired network was active, but now there is no sign of a USB device being 
plugged in (at least I don't think there is). I'm running ubuntu 12.04 
on a Macbook Pro:
lsusb:
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 05ac:8507 Apple, Inc. Built-in iSight
Bus 004 Device 002: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub 
(part of BCM2046 Bluetooth)
Bus 003 Device 002: ID 05ac:8242 Apple, Inc. IR Receiver [built-in]
Bus 003 Device 003: ID 05ac:0236 Apple, Inc. Internal Keyboard/Trackpad 
(ANSI)
Bus 004 Device 004: ID 05ac:8213 Apple, Inc.

So am I right in saying that I have a flat battery that won't charge?
Or have I missed something important along the way?
Any suggestions for the next step I should try, or is there any further 
information I should supply?
kind regards,
Sam
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20121022/1c9b03a4/attachment.html>


More information about the Gta04-owner mailing list