[Gta04-owner] Experimental QtMoko/GTA04 build for armhf

Gilles Filippini gilles.filippini at free.fr
Sun Oct 7 10:32:36 CEST 2012


Gilles Filippini a écrit , Le 05/10/2012 23:45:
> But I first had the error "/opt/qtmoko/qpe: no such file or directory"
> while the binary is right there. It's because it looks for ld-linux.so.3
> in /lib while there is only ld-linux-armhf.so.3.
> 
> readelf -a /opt/qtmoko/qpe says:
>       [Requesting program interpreter: /lib/ld-linux.so.3]
> whereas it says:
>       [Requesting program interpreter: /lib/ld-linux-armhf.so.3]
> for the distro's binaries.
> 
> I've had to create the symlink ld-linux.so.3 -> ld-linux-armhf.so.3 to
> workaround the problem.

Solved by building with gcc-4.6 (instead of 4.4).

Thanks,

_g.


More information about the Gta04-owner mailing list