[Gta04-owner] [QtMoko] Wifi

e.waelde ew.ng7125 at nassur.net
Thu Nov 29 13:07:40 CET 2012


Hello,

On 11/29/2012 12:49 PM, Griera wrote:
> Hello:
>
> I am trying to use the wifi GTA04, but did not work. I've done:
>
>     root at neo:~# apt-get install libertas-firmware wireless-tools
>     root at neo:~# root at neo:~# sh /opt/qtmoko/bin/wifi-poweron.sh
>         error binding control socket, seems udevd is already running
>         WARNING: All config files need .conf: /etc/modprobe.d/options, it will be ignored in a future release.
>     root at neo:~# iwconfig
>         hso0      no wireless extensions.
>         lo        no wireless extensions.
>         usb0      no wireless extensions.
>         pan0      no wireless extensions.
>     root at neo:~#
>     root at neo:~# iwlist pan0 scan
>         pan0      Interface doesn't support scanning.
>
> Any clue what I'm doing wrong?

"ifconfig -a" should list all devices, regardless, whether they
are configured or not (output edited):

hso0      Link encap:UNSPEC  HWaddr 
00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
           POINTOPOINT NOARP MULTICAST  MTU:1486  Metric:1
...
lo        Link encap:Local Loopback
           inet addr:127.0.0.1  Mask:255.0.0.0
...
pan0      Link encap:Ethernet  HWaddr d6:08:50:c9:08:7c
           BROADCAST MULTICAST  MTU:1500  Metric:1
...
usb0      Link encap:Ethernet  HWaddr b6:c8:ab:ac:44:7f
           inet addr:192.168.0.202 ...
...
wlan0     Link encap:Ethernet  HWaddr 00:19:88:14:82:13
           BROADCAST MULTICAST  MTU:1500  Metric:1
           RX packets:0 errors:0 dropped:0 overruns:0 frame:0
           TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
           collisions:0 txqueuelen:1000
           RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0 is the wireless interface. Bring it up:
root at neo:~# ifconfig wlan0 up
root at neo:~# echo $?
0
root at neo:~# ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 00:19:88:14:82:13
           UP BROADCAST MULTICAST  MTU:1500  Metric:1
           RX packets:0 errors:0 dropped:0 overruns:0 frame:0
           TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
           collisions:0 txqueuelen:1000
           RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

Then try iwconfig again:
root at neo:~# iwconfig wlan0
wlan0     IEEE 802.11bg  ESSID:off/any
           Mode:Managed  Access Point: Not-Associated
           Retry  long limit:7   RTS thr:off   Fragment thr:off
           Encryption key:off
           Power Management:on
root at neo:~# iwlist wlan0 scan
wlan0     No scan results

if you cannot see "wlan0", then something else is wrong.

Cheers,
Erich


More information about the Gta04-owner mailing list