[Gta04-owner] Bluetooth handsfree unit

Gilles Filippini gilles.filippini at free.fr
Wed Nov 28 00:17:29 CET 2012


Gilles Filippini a écrit , Le 27/11/2012 15:46:
>> It's v49. It appears as soon as I click on "Connect AD2P".
> I didn't see this option, but maybe it's because I've only tried phone
> handsfree units so far. I'll try with a Motorola S305 headset this
> evening.

Restarted with a fresh install of QtMoko v50 (Debian Squeeze armel), and
I can now hear my favorite song in my Motorola S305 headset \o/
I'll need now to understand what's different from my Debian Wheezy armhf
installation.

There are still problems though: once it is connected as A2DP, it's
impossible to reconnect it afterward:
* it always connects automatically in A2DP mode (I hear the
corresponding beeps in the headset)
* the gui says it isn't connected
* it fails to connect in handsfree mode
* when trying A2DP it fails with org.bluez.AudioSink.Connect() saying
"Device Already Connected". (but the gui still fails to notice this)

The only way I've found is to poweroff the headset, then remove the
paired device then pairing again with the headset powered on.

Then, while paired in handsfree unit mode, I've tried to place a call to
voicemail and the symptoms are the very same as those I reported initially:
* I can answer and end calls
* but no sound on either side, whatever sound profile I select during
the call: bluetooth headset, speaker, earpiece.
* btw, none of these profiles is selected when the call starts.
* I can hear an occasional sound artifact from time to time on the
device, independently of the call context.

Thanks!

_g.


More information about the Gta04-owner mailing list