[Gta04-owner] battery status [Was: QtMoko v49]

Heinz Matusch heinz.matusch at utanet.at
Sun Nov 25 22:34:52 CET 2012


Hi all,

i have the same Problem here.
two batteries, with one the icon is ok, with the second, only the red lined 
rectangle is advisable. 
(on my EA-Board, qtmoko 49 hang on boot, only the Clock is visible until i 
restart dbus over the ssh-conection, but thats another Problem at the moment)   

today i tested replicant with the second battery and all looks ok.

maybe a initialization problem in the Kernel?

br, heinz

Am Sonntag, 25. November 2012, 19:09:30 schrieb EdorFaus:
> On 11/18/2012 07:18 PM, arne anka wrote:
> > - the battery symbol in the upper right corner is only a red frame, no
> > capacity indication. when connected to usb sometimes a flash symbol
> > appears inside, but only for a short time and disappears again. battery
> > is a default gat02 battery.
> 
> On 11/20/2012 09:10 PM, arne anka wrote:
> > root at neo:/sys/class/power_supply/bq27000-battery# for i in *; do echo
> > "file: "$i; cat $i ; echo ; done
> > file: capacity
> > cat: capacity: No data available
> > 
> > file: cycle_count
> > 228
> 
> If it wasn't for this cycle count, and that it (I presume) has worked
> fine before, I would think your problem was the same as the one I had
> with my brand new battery (since the symptoms are pretty much identical
> otherwise): that the battery isn't calibrated.
> 
> I fixed that for my battery by charging it as full as it would go (the
> gta04 stops charging it well before it it reaches the design capacity),
> and then discharging it completely - I'm not sure if that's the correct
> procedure (for all I know I may have ruined my battery by doing it), but
> the battery started giving info once it had a bit of charge again, so it
> at least appears to have worked, for me at least.
> 
> It seems a bit odd if that's the problem with yours, though, since it's
> not a brand new and never before calibrated battery like mine was...
> Still, if nothing else works, might be worth a try.
> 
> -Frode
> _______________________________________________
> Gta04-owner mailing list
> Gta04-owner at goldelico.com
> http://lists.goldelico.com/mailman/listinfo/gta04-owner


More information about the Gta04-owner mailing list