[Gta04-owner] Replicant GTA04 : suspend bug

Paul Kocialkowski paulk at paulk.fr
Sun Nov 25 16:59:57 CET 2012


Le samedi 24 novembre 2012 à 22:01 +0100, Adrien Dorsaz a écrit :
> I've finally succeed to install replicant (2.3 image 5) on my gta04 (I
> took some times to understand that I had to first install replicant
> bootloader and only then use system microSD).

I will work to make this more standard in the next releases.
Also, replicant bootloader is just Goldelico U-Boot, it's just the
latest version at the moment of the release, but any other u-boot will
work as well.

> That's really good but as noticed on the wiki, there's an issue with the
> suspend. I've noticed some strange behavior : 
>      1. plug your GTA04 on your computer, set it to debug mode
>      2. check the option to not suspend (this option is available in the
>         notification bar when you click on the debug notification)
>      3. click on power button in the home to suspend
>      4. click again on power and you can resume without issue

Yes, in some cases such as this one, suspend/resume works. If you try
playing music and then suspend (even if not connected via USB), resume
will always work too.

Android seems to use standard Linux suspend/resume process, so I guess
the problem is in the kernel. I will need to investigate that a bit more
when porting to Replicant 4.0.

> I've also noticed that without point 2, you can suspend and resume, but
> only once.

Thanks for the report!


-- 
Paul Kocialkowski, Replicant developer

Replicant is a fully free Android distribution

Website:        http://www.replicant.us
Wiki/Tracker:   http://redmine.replicant.us



More information about the Gta04-owner mailing list