[Gta04-owner] New U-Boot, Multi-Boot-Menu, recommendations for Distros

A.dre A.dre at net.HCC.nl
Sat Nov 17 01:20:05 CET 2012


On 11/16/2012 10:53 PM, arne anka wrote:
>> B) installing kernel and rootfs on SD card(s)
>>
>> * format your SD card with one or more ext2/3/4 partition(s) - no need
>>    for using makesd any more
>> * install the system(s) you like to the partition(s) [make sure the 
>> kernel
>>    and the bootargs.scr is found in /boot]
>> * just power on to boot from SD. This will boot the last choosen system.
>> * if you want to boot a different system, power on with AUX button
>>    pressed and choose the first partition to be searched for by the
>>    SD:1 ... SD:4 buttons
>> * you can also choose to boot from NAND - in this case the SD card
>>    is skipped even if there is a valid Linux system
>> * the boot order is stored in NAND flash so that the next power on
>>    will use the same search order. The result may be different of course
>>    if you have swapped the SD card...
>
>
> doesn't work for me with the squeeze-lxde.tbz.
> i created 4 ext4 partitions, expanded the squeeze-lxde.tbz to the 
> first and copied
>
> boot.scr
> bootargs.scr
> menu.rgb16z
> splash.rgb16z
> uImage
>
> from http://download.goldelico.com/gta04/20121030-GTA04-Production/ to 
> its boot/ directory.
> still, it never boots from SD but always from NAND.

It didn't work for me neither. I can not provide any answers to your 
questions. I can give you my story:


I had 4x ext3, tried with SHR and QtMoko. (IIRC, the phone had an 
infinite loop of boot attempts while holding aux. When only holding aux 
during the first boot it hung itself after choosing the microSD-icon.)

I then used makesd from ..../20121030-GTA04-Production. During first 
boot I held aux. The screen turned red. From what I understand is that 
red means that U-Boot is flashed to NAND.
- Is this correct? And only U-boot or also other files?

Then I selected P2 and it booted from P2.

I went on to create P3 and P4. (I had tweaked maksd to not use the 
entire SDcard.) At that point I had: P1 FAT; P2,P3 and P4 ext3. I put 
SHR on both P2 and P3 as described in [1]
- First it booted from P2 not from P3
- After removing all files from P1 (the FAT partition) same result, but 
(IIRC) with uImage appearing on P1!
- After renaming uImage from P1 and uImage from P2/boot to SHRuImage and 
SHR2uImage resp., same result
- I checked `cat /proc/version`: see [2]
- When booting from NAND I have a different /proc/version.
- So I thought uImage is coming from P3 and rootfs from P2.
- I then edited P3/boot/bootargs.scr [3] (No idea if you can do this in 
vi) and emptied P1/* and P2/boot/* . Same result.
- I emptied P3/boot/*. Now it boots form (surprise) NAND.

How can I check version / validity of bootloaderfiles in NAND?
And how can I provide a correct bootargs.scr?

Kind regards,
André

[1] http://shr-project.org/trac/wiki/Devices/GTA04/InstallGuide
[2] Linux version 3.4.9 (bitbake at opmbuild) (gcc version 4.7.2 (GCC) ) #1 
PREEMPT Tue Oct 16 21:41:18 CEST 2012
[3] 5 occurrences of >setenv mmcroot "/dev/mmcblk0p* rw"< all changed  
to >..."/dev/mmcblk0p3 rw"<

>
> while i am at it:
> - how can i enable boot messages? i really don't like this awkward 
> silence with only a penguin
> - how do i compile boot.scr/bootargs.scr from the *txt files?
> - how do i know what exactly is booted (with the lxde image in both 
> NAND and on SD its  difficult to tell which one booted w/o loggin via 
> ssh or checking in terminal)
> _______________________________________________
> Gta04-owner mailing list
> Gta04-owner at goldelico.com
> http://lists.goldelico.com/mailman/listinfo/gta04-owner
>



More information about the Gta04-owner mailing list